aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/patches-4.4/0002-MIPS-lantiq-dtb-image-hack.patch
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2016-03-20 14:41:54 +0000
committerJohn Crispin <john@openwrt.org>2016-03-20 14:41:54 +0000
commitd6d0597cdf2f8fc7ba305a920c20a7fb912d8401 (patch)
tree8c15f4a8db38d1c30678c3f9bbdff3279809d24d /target/linux/lantiq/patches-4.4/0002-MIPS-lantiq-dtb-image-hack.patch
parent217a64375547a6a5f2aba81bd1dcb0b99148c2ba (diff)
downloadupstream-d6d0597cdf2f8fc7ba305a920c20a7fb912d8401.tar.gz
upstream-d6d0597cdf2f8fc7ba305a920c20a7fb912d8401.tar.bz2
upstream-d6d0597cdf2f8fc7ba305a920c20a7fb912d8401.zip
lantiq: use upstream mechanism to append device tree file
Instead of using our patch-dtb program just place the device tree behind the kernel binary and then let the in kernel mechanism fetch it. This also adds support for having the device tree file in the boot loader. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> SVN-Revision: 49050
Diffstat (limited to 'target/linux/lantiq/patches-4.4/0002-MIPS-lantiq-dtb-image-hack.patch')
-rw-r--r--target/linux/lantiq/patches-4.4/0002-MIPS-lantiq-dtb-image-hack.patch31
1 files changed, 0 insertions, 31 deletions
diff --git a/target/linux/lantiq/patches-4.4/0002-MIPS-lantiq-dtb-image-hack.patch b/target/linux/lantiq/patches-4.4/0002-MIPS-lantiq-dtb-image-hack.patch
deleted file mode 100644
index 89a498d4c7..0000000000
--- a/target/linux/lantiq/patches-4.4/0002-MIPS-lantiq-dtb-image-hack.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From 17348293f7f8103c97c8d2a6b0ef36eae06ec371 Mon Sep 17 00:00:00 2001
-From: John Crispin <blogic@openwrt.org>
-Date: Wed, 13 Mar 2013 09:36:16 +0100
-Subject: [PATCH 02/36] MIPS: lantiq: dtb image hack
-
-Signed-off-by: John Crispin <blogic@openwrt.org>
----
- arch/mips/lantiq/Makefile | 2 --
- arch/mips/lantiq/prom.c | 4 +++-
- 2 files changed, 3 insertions(+), 3 deletions(-)
-
---- a/arch/mips/lantiq/prom.c
-+++ b/arch/mips/lantiq/prom.c
-@@ -63,6 +63,8 @@ static void __init prom_init_cmdline(voi
- }
- }
-
-+extern struct boot_param_header __image_dtb;
-+
- void __init plat_mem_setup(void)
- {
- ioport_resource.start = IOPORT_RESOURCE_START;
-@@ -76,7 +78,7 @@ void __init plat_mem_setup(void)
- * Load the builtin devicetree. This causes the chosen node to be
- * parsed resulting in our memory appearing
- */
-- __dt_setup_arch(__dtb_start);
-+ __dt_setup_arch(&__image_dtb);
- }
-
- void __init device_tree_init(void)