aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ixp4xx/profiles
diff options
context:
space:
mode:
authorRod Whitby <rod@whitby.id.au>2007-12-07 22:29:44 +0000
committerRod Whitby <rod@whitby.id.au>2007-12-07 22:29:44 +0000
commit610fcbfd85d83accda5ce69e12b343b4a49da11e (patch)
treeac1db4a62540a9b30d38b1ede774a55ca52480ba /target/linux/ixp4xx/profiles
parent691be1ebe34e6658b3167fb1debf9c928d581ca1 (diff)
downloadupstream-610fcbfd85d83accda5ce69e12b343b4a49da11e.tar.gz
upstream-610fcbfd85d83accda5ce69e12b343b4a49da11e.tar.bz2
upstream-610fcbfd85d83accda5ce69e12b343b4a49da11e.zip
ixp4xx: Split into two subtargets, one normal and one for boards which boot directly from attached storage (and therefore need most kernel modules compiled in)
SVN-Revision: 9669
Diffstat (limited to 'target/linux/ixp4xx/profiles')
-rw-r--r--target/linux/ixp4xx/profiles/100-Default.mk17
-rw-r--r--target/linux/ixp4xx/profiles/200-NSLU2.mk20
-rw-r--r--target/linux/ixp4xx/profiles/300-NAS100d.mk22
-rw-r--r--target/linux/ixp4xx/profiles/400-DSMG600RevA.mk22
-rw-r--r--target/linux/ixp4xx/profiles/500-FSG3.mk20
5 files changed, 0 insertions, 101 deletions
diff --git a/target/linux/ixp4xx/profiles/100-Default.mk b/target/linux/ixp4xx/profiles/100-Default.mk
deleted file mode 100644
index 104268bd8e..0000000000
--- a/target/linux/ixp4xx/profiles/100-Default.mk
+++ /dev/null
@@ -1,17 +0,0 @@
-#
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Default
- NAME:=Default Profile
- PACKAGES:=kmod-madwifi
-endef
-
-define Profile/Default/Description
- Default IXP4xx Profile
-endef
-$(eval $(call Profile,Default))
-
diff --git a/target/linux/ixp4xx/profiles/200-NSLU2.mk b/target/linux/ixp4xx/profiles/200-NSLU2.mk
deleted file mode 100644
index a4e1a30858..0000000000
--- a/target/linux/ixp4xx/profiles/200-NSLU2.mk
+++ /dev/null
@@ -1,20 +0,0 @@
-#
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/NSLU2
- NAME:=Linksys NSLU2
- PACKAGES:=kmod-ixp4xx-npe \
- kmod-scsi-core \
- kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-usb-storage \
- kmod-fs-ext2 kmod-fs-ext3
-endef
-
-define Profile/NSLU2/Description
- Package set optimized for the Linksys NSLU2
-endef
-$(eval $(call Profile,NSLU2))
-
diff --git a/target/linux/ixp4xx/profiles/300-NAS100d.mk b/target/linux/ixp4xx/profiles/300-NAS100d.mk
deleted file mode 100644
index 2a43ac6d9b..0000000000
--- a/target/linux/ixp4xx/profiles/300-NAS100d.mk
+++ /dev/null
@@ -1,22 +0,0 @@
-#
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/NAS100d
- NAME:=Iomega NAS 100d
- PACKAGES:=kmod-ixp4xx-npe \
- kmod-madwifi wireless-tools \
- kmod-scsi-core \
- kmod-ata-core kmod-ata-artop \
- kmod-usb-core kmod-usb2 kmod-usb-storage \
- kmod-fs-ext2 kmod-fs-ext3
-endef
-
-define Profile/NAS100d/Description
- Package set optimized for the Iomega NAS 100d
-endef
-$(eval $(call Profile,NAS100d))
-
diff --git a/target/linux/ixp4xx/profiles/400-DSMG600RevA.mk b/target/linux/ixp4xx/profiles/400-DSMG600RevA.mk
deleted file mode 100644
index aa2c64217e..0000000000
--- a/target/linux/ixp4xx/profiles/400-DSMG600RevA.mk
+++ /dev/null
@@ -1,22 +0,0 @@
-#
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/DSMG600RevA
- NAME:=DSM-G600 Rev A
- PACKAGES:=kmod-via-velocity \
- kmod-madwifi wireless-tools \
- kmod-scsi-core \
- kmod-ata-core kmod-ata-artop \
- kmod-usb-core kmod-usb-uhci kmod-usb2 kmod-usb-storage \
- kmod-fs-ext2 kmod-fs-ext3
-endef
-
-define Profile/DSMG600RevA/Description
- Package set optimized for the DSM-G600 Rev A
-endef
-$(eval $(call Profile,DSMG600RevA))
-
diff --git a/target/linux/ixp4xx/profiles/500-FSG3.mk b/target/linux/ixp4xx/profiles/500-FSG3.mk
deleted file mode 100644
index f06fa8c66f..0000000000
--- a/target/linux/ixp4xx/profiles/500-FSG3.mk
+++ /dev/null
@@ -1,20 +0,0 @@
-#
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/FSG3
- NAME:=Freecom FSG-3
- PACKAGES:= \
- kmod-madwifi wireless-tools \
- kmod-usb-core kmod-usb-uhci kmod-usb2 kmod-usb-storage \
- kmod-fs-ext2 kmod-fs-reiserfs
-endef
-
-define Profile/FSG3/Description
- Package set optimized for the Freecom FSG-3
-endef
-$(eval $(call Profile,FSG3))
-