aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.0/201-extra_optimization.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-05-14 15:48:34 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-05-14 15:48:34 +0000
commit2fceae7ec4276e500af566959911547100ab17eb (patch)
tree468119a66c66365e737d9de974e4a405abac8758 /target/linux/generic/patches-3.0/201-extra_optimization.patch
parenta3d349a3b303b349678f25caf341f969654e801c (diff)
downloadupstream-2fceae7ec4276e500af566959911547100ab17eb.tar.gz
upstream-2fceae7ec4276e500af566959911547100ab17eb.tar.bz2
upstream-2fceae7ec4276e500af566959911547100ab17eb.zip
linux/3.0: R.I.P.
It is used by the broken omap35xx/gumstix target only. SVN-Revision: 31717
Diffstat (limited to 'target/linux/generic/patches-3.0/201-extra_optimization.patch')
-rw-r--r--target/linux/generic/patches-3.0/201-extra_optimization.patch24
1 files changed, 0 insertions, 24 deletions
diff --git a/target/linux/generic/patches-3.0/201-extra_optimization.patch b/target/linux/generic/patches-3.0/201-extra_optimization.patch
deleted file mode 100644
index 6fe8b0938d..0000000000
--- a/target/linux/generic/patches-3.0/201-extra_optimization.patch
+++ /dev/null
@@ -1,24 +0,0 @@
---- a/Makefile
-+++ b/Makefile
-@@ -559,9 +559,9 @@ endif # $(dot-config)
- all: vmlinux
-
- ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
--KBUILD_CFLAGS += -Os
-+KBUILD_CFLAGS += -Os -fno-caller-saves
- else
--KBUILD_CFLAGS += -O2
-+KBUILD_CFLAGS += -O2 -fno-reorder-blocks -fno-tree-ch -fno-caller-saves
- endif
-
- include $(srctree)/arch/$(SRCARCH)/Makefile
-@@ -620,6 +620,9 @@ endif
- NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
- CHECKFLAGS += $(NOSTDINC_FLAGS)
-
-+# improve gcc optimization
-+CFLAGS += $(call cc-option,-funit-at-a-time,)
-+
- # warn about C99 declaration after statement
- KBUILD_CFLAGS += $(call cc-option,-Wdeclaration-after-statement,)
-