aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-2.6.36/012-extra_optimization.patch
diff options
context:
space:
mode:
authorAlexandros C. Couloumbis <alex@ozo.com>2010-08-29 14:35:23 +0000
committerAlexandros C. Couloumbis <alex@ozo.com>2010-08-29 14:35:23 +0000
commit206e5f313e425c2b727b64a023a62c1f3de59b72 (patch)
treed7d49f33d5b291ac9f72b066866fdc293cf47dc7 /target/linux/generic/patches-2.6.36/012-extra_optimization.patch
parent28d7de48b8c1150b5d72da89a9fb51f271843579 (diff)
downloadupstream-206e5f313e425c2b727b64a023a62c1f3de59b72.tar.gz
upstream-206e5f313e425c2b727b64a023a62c1f3de59b72.tar.bz2
upstream-206e5f313e425c2b727b64a023a62c1f3de59b72.zip
linux/generic: add kernel 2.6.36 preliminary support
SVN-Revision: 22832
Diffstat (limited to 'target/linux/generic/patches-2.6.36/012-extra_optimization.patch')
-rw-r--r--target/linux/generic/patches-2.6.36/012-extra_optimization.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/generic/patches-2.6.36/012-extra_optimization.patch b/target/linux/generic/patches-2.6.36/012-extra_optimization.patch
new file mode 100644
index 0000000000..b5f4f393af
--- /dev/null
+++ b/target/linux/generic/patches-2.6.36/012-extra_optimization.patch
@@ -0,0 +1,21 @@
+--- a/Makefile
++++ b/Makefile
+@@ -532,7 +532,7 @@ all: vmlinux
+ ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
+ KBUILD_CFLAGS += -Os
+ else
+-KBUILD_CFLAGS += -O2
++KBUILD_CFLAGS += -O2 -fno-reorder-blocks -fno-tree-ch
+ endif
+
+ include $(srctree)/arch/$(SRCARCH)/Makefile
+@@ -570,6 +570,9 @@ endif
+ NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
+ CHECKFLAGS += $(NOSTDINC_FLAGS)
+
++# improve gcc optimization
++CFLAGS += $(call cc-option,-funit-at-a-time,)
++
+ # warn about C99 declaration after statement
+ KBUILD_CFLAGS += $(call cc-option,-Wdeclaration-after-statement,)
+