aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.33/402-ledtrig_netdev.patch
diff options
context:
space:
mode:
authorMatteo Croce <rootkit85@yahoo.it>2010-02-28 15:20:00 +0000
committerMatteo Croce <rootkit85@yahoo.it>2010-02-28 15:20:00 +0000
commit5ddd984cff128820f07b1f8e0ac7f8c845685855 (patch)
treebead993f23911a151c0afab7c1f7f7a12bac9737 /target/linux/generic-2.6/patches-2.6.33/402-ledtrig_netdev.patch
parent9fd2d20a246341b7b510de5a2de86d1f93a12887 (diff)
downloadupstream-5ddd984cff128820f07b1f8e0ac7f8c845685855.tar.gz
upstream-5ddd984cff128820f07b1f8e0ac7f8c845685855.tar.bz2
upstream-5ddd984cff128820f07b1f8e0ac7f8c845685855.zip
kernel: add 2.6.33 patches
SVN-Revision: 19905
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.33/402-ledtrig_netdev.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.33/402-ledtrig_netdev.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.33/402-ledtrig_netdev.patch b/target/linux/generic-2.6/patches-2.6.33/402-ledtrig_netdev.patch
new file mode 100644
index 0000000000..d4ac25edec
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.33/402-ledtrig_netdev.patch
@@ -0,0 +1,21 @@
+--- a/drivers/leds/Kconfig
++++ b/drivers/leds/Kconfig
+@@ -341,4 +341,11 @@ config LEDS_TRIGGER_MORSE
+ tristate "LED Morse Trigger"
+ depends on LEDS_TRIGGERS
+
++config LEDS_TRIGGER_NETDEV
++ tristate "LED Netdev Trigger"
++ depends on LEDS_TRIGGERS
++ help
++ This allows LEDs to be controlled by network device activity.
++ If unsure, say Y.
++
+ endif # NEW_LEDS
+--- a/drivers/leds/Makefile
++++ b/drivers/leds/Makefile
+@@ -45,3 +45,4 @@ obj-$(CONFIG_LEDS_TRIGGER_BACKLIGHT) +=
+ obj-$(CONFIG_LEDS_TRIGGER_GPIO) += ledtrig-gpio.o
+ obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
+ obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o
++obj-$(CONFIG_LEDS_TRIGGER_NETDEV) += ledtrig-netdev.o