aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm63xx/profiles/d-link.mk
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2014-08-18 21:50:40 +0000
committerJonas Gorski <jogo@openwrt.org>2014-08-18 21:50:40 +0000
commit3db93a335199eb1127616826a84324403ad4aafe (patch)
treec23a17c6e3929f28472fb7ceb342e8114eac7bcb /target/linux/brcm63xx/profiles/d-link.mk
parent84ea696e031eb88f1f57700f24ca315fb2a3372c (diff)
downloadupstream-3db93a335199eb1127616826a84324403ad4aafe.tar.gz
upstream-3db93a335199eb1127616826a84324403ad4aafe.tar.bz2
upstream-3db93a335199eb1127616826a84324403ad4aafe.zip
brcm63xx: add profiles for DTB supported devices
Remove generic profiles and add profiles for each DTB supported device. Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com> Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 42209
Diffstat (limited to 'target/linux/brcm63xx/profiles/d-link.mk')
-rw-r--r--target/linux/brcm63xx/profiles/d-link.mk25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/brcm63xx/profiles/d-link.mk b/target/linux/brcm63xx/profiles/d-link.mk
new file mode 100644
index 0000000000..f2eedd6637
--- /dev/null
+++ b/target/linux/brcm63xx/profiles/d-link.mk
@@ -0,0 +1,25 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/DSL274XB_C
+ NAME:=D-Link DSL-2740B/DSL-2741B rev C2/C3
+ PACKAGES:=kmod-b43 wpad-mini
+endef
+define Profile/DSL274XB_C/Description
+ Package set optimized for DSL-2740B/DSL-2741B rev C2/C3.
+endef
+$(eval $(call Profile,DSL274XB_C))
+
+define Profile/DVAG3810BN
+ NAME:=D-Link DVA-G3810BN/TL
+ PACKAGES:=kmod-b43 wpad-mini \
+ kmod-usb2 kmod-usb-ohci
+endef
+define Profile/DVAG3810BN/Description
+ Package set optimized for DVA-G3810BN/TL.
+endef
+$(eval $(call Profile,DVAG3810BN))