aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm63xx/patches-2.6.30/020-watchdog.patch
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2009-08-01 16:56:36 +0000
committerFlorian Fainelli <florian@openwrt.org>2009-08-01 16:56:36 +0000
commit85119470d2e01c425aa40773e406d11b8375593d (patch)
treebedf450f4de1858297d99b2d7e86841a4aae4788 /target/linux/brcm63xx/patches-2.6.30/020-watchdog.patch
parent6e65f0080d362fb47b780cfa36dfcae319feeb2b (diff)
downloadupstream-85119470d2e01c425aa40773e406d11b8375593d.tar.gz
upstream-85119470d2e01c425aa40773e406d11b8375593d.tar.bz2
upstream-85119470d2e01c425aa40773e406d11b8375593d.zip
add experimental support for 2.6.30.4
SVN-Revision: 17081
Diffstat (limited to 'target/linux/brcm63xx/patches-2.6.30/020-watchdog.patch')
-rw-r--r--target/linux/brcm63xx/patches-2.6.30/020-watchdog.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/target/linux/brcm63xx/patches-2.6.30/020-watchdog.patch b/target/linux/brcm63xx/patches-2.6.30/020-watchdog.patch
new file mode 100644
index 0000000000..302c6c79b7
--- /dev/null
+++ b/target/linux/brcm63xx/patches-2.6.30/020-watchdog.patch
@@ -0,0 +1,29 @@
+--- a/drivers/watchdog/Makefile
++++ b/drivers/watchdog/Makefile
+@@ -105,6 +105,7 @@ obj-$(CONFIG_WDT_RM9K_GPI) += rm9k_wdt.o
+ obj-$(CONFIG_SIBYTE_WDOG) += sb_wdog.o
+ obj-$(CONFIG_AR7_WDT) += ar7_wdt.o
+ obj-$(CONFIG_TXX9_WDT) += txx9wdt.o
++obj-$(CONFIG_BCM63XX_WDT) += bcm63xx_wdt.o
+
+ # PARISC Architecture
+
+--- a/drivers/watchdog/Kconfig
++++ b/drivers/watchdog/Kconfig
+@@ -764,6 +764,16 @@ config TXX9_WDT
+ help
+ Hardware driver for the built-in watchdog timer on TXx9 MIPS SoCs.
+
++config BCM63XX_WDT
++ tristate "Broadcom BCM63xx hardware watchdog"
++ depends on BCM63XX
++ help
++ Watchdog driver for the built in watchdog hardware in Broadcom
++ BCM63xx SoC.
++
++ To compile thi driver as a loadable module, choose M here.
++ The module will be called bcm63xx_wdt.
++
+ # PARISC Architecture
+
+ # POWERPC Architecture