aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bmips/image
diff options
context:
space:
mode:
authorÁlvaro Fernández Rojas <noltari@gmail.com>2023-03-22 20:10:01 +0100
committerÁlvaro Fernández Rojas <noltari@gmail.com>2023-03-22 20:57:07 +0100
commit6df12200d903338d36008cb207a41bd456346b5d (patch)
tree79b12e64b5cb36414a1babaeabb40ff44af38811 /target/linux/bmips/image
parentcc07d1d2fd3662611e2044c9fc514f7f756ebd6d (diff)
downloadupstream-6df12200d903338d36008cb207a41bd456346b5d.tar.gz
upstream-6df12200d903338d36008cb207a41bd456346b5d.tar.bz2
upstream-6df12200d903338d36008cb207a41bd456346b5d.zip
bmips: add support for Sercomm H-500s
Sercomm H-500s is a BCM63268 with 128M, internal and external (Quantenna) wifi and external BCM53134S switch. This device is already supported in bcm63xx target, so more information can be found in https://openwrt.org/toh/sercomm/h500-s. It's a perfect example of a device with internal and external switch coexistance since most devices only have ports on one of the switches but not both of them. Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
Diffstat (limited to 'target/linux/bmips/image')
-rw-r--r--target/linux/bmips/image/bcm63xx_nand.mk54
1 files changed, 54 insertions, 0 deletions
diff --git a/target/linux/bmips/image/bcm63xx_nand.mk b/target/linux/bmips/image/bcm63xx_nand.mk
index 6c4655bbab..01540625ed 100644
--- a/target/linux/bmips/image/bcm63xx_nand.mk
+++ b/target/linux/bmips/image/bcm63xx_nand.mk
@@ -100,3 +100,57 @@ define Device/netgear_dgnd3700-v2
CFE_WFI_VERSION := 0x5731
endef
TARGET_DEVICES += netgear_dgnd3700-v2
+
+define Device/sercomm_h500-s-lowi
+ $(Device/sercomm-nand)
+ DEVICE_VENDOR := Sercomm
+ DEVICE_MODEL := H500-s
+ DEVICE_VARIANT := lowi
+ DEVICE_LOADADDR := $(KERNEL_LOADADDR)
+ KERNEL := kernel-bin | append-dtb | lzma | cfe-jffs2-kernel
+ CHIP_ID := 63268
+ SOC := bcm63167
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ SUBPAGESIZE := 512
+ VID_HDR_OFFSET := 2048
+ DEVICE_PACKAGES += $(USB2_PACKAGES)
+ SERCOMM_PID := \
+ 30 30 30 30 30 30 30 31 34 33 34 62 33 31 30 30 \
+ 30 30 30 30 30 30 30 30 30 30 30 30 30 30 30 30 \
+ 30 30 30 30 30 30 30 30 30 30 30 30 30 30 30 30 \
+ 30 30 30 30 30 30 30 30 30 30 30 30 30 30 30 30 \
+ 30 30 30 30 30 30 30 30 30 30 30 30 30 30 30 30 \
+ 30 30 30 30 30 30 30 30 30 30 30 30 30 30 30 30 \
+ 30 30 30 30 33 33 30 35 30 30 30 30 30 30 30 30 \
+ 0D 0A 00 00 00 00 00 00 00 00 00 00 00 00 00 00
+ SERCOMM_VERSION := 1001
+endef
+TARGET_DEVICES += sercomm_h500-s-lowi
+
+define Device/sercomm_h500-s-vfes
+ $(Device/sercomm-nand)
+ DEVICE_VENDOR := Sercomm
+ DEVICE_MODEL := H500-s
+ DEVICE_VARIANT := vfes
+ DEVICE_LOADADDR := $(KERNEL_LOADADDR)
+ KERNEL := kernel-bin | append-dtb | lzma | cfe-jffs2-kernel
+ CHIP_ID := 63268
+ SOC := bcm63167
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ SUBPAGESIZE := 512
+ VID_HDR_OFFSET := 2048
+ DEVICE_PACKAGES += $(USB2_PACKAGES)
+ SERCOMM_PID := \
+ 30 30 30 30 30 30 30 31 34 32 35 38 34 62 30 30 \
+ 30 30 30 30 30 30 30 30 30 30 30 30 30 30 30 30 \
+ 30 30 30 30 30 30 30 30 30 30 30 30 30 30 30 30 \
+ 30 30 30 30 30 30 30 30 30 30 30 30 30 30 30 30 \
+ 30 30 30 30 30 30 30 30 30 30 30 30 30 30 30 30 \
+ 30 30 30 30 30 30 30 30 30 30 30 30 30 30 30 30 \
+ 30 30 30 30 33 34 31 37 30 30 30 30 30 30 30 30 \
+ 0D 0A 00 00 00 00 00 00 00 00 00 00 00 00 00 00
+ SERCOMM_VERSION := 1001
+endef
+TARGET_DEVICES += sercomm_h500-s-vfes