aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bmips/image/bcm6328.mk
diff options
context:
space:
mode:
authorDaniel González Cabanelas <dgcbueu@gmail.com>2023-06-18 21:34:59 +0200
committerÁlvaro Fernández Rojas <noltari@gmail.com>2023-06-19 20:42:44 +0200
commitac6832110ac4a6c6f2c4a789d2ab6fa4075a6bfc (patch)
tree80b3f35c638f9b32f514d76cfcdd77f88ebda568 /target/linux/bmips/image/bcm6328.mk
parent43746c4c5a85e1762edf383909f1734ad0543825 (diff)
downloadupstream-ac6832110ac4a6c6f2c4a789d2ab6fa4075a6bfc.tar.gz
upstream-ac6832110ac4a6c6f2c4a789d2ab6fa4075a6bfc.tar.bz2
upstream-ac6832110ac4a6c6f2c4a789d2ab6fa4075a6bfc.zip
bmips: add support for NuCom R5010UNv2
The NuCom R5010UNv2 is a wifi fast ethernet router, 2.4 GHz single band with two external antennas. Hardware: - SoC: Broadcom BCM6328 - CPU: single core BMIPS4350 V7.5 @ 320Mhz - RAM: 64 MB DDR2 - Flash: 16 MB SPI NOR - Ethernet LAN: 4x 100Mbit - Wifi 2.4 GHz: Broadcom BCM43217 802.11bgn (onboard) - USB: 1x 2.0 - Buttons: 2x - ADSL: yes, unsupported - LEDs: 7x - UART: yes Installation via CFE web UI: 1. Power off the router and press the RESET button 2. Power on the router and wait 12 or more seconds 3. Release the RESET button 4. Browse to http://192.168.1.1 and upload the Openwrt cfe firmware 5. Wait a few minutes for it to finish Signed-off-by: Daniel González Cabanelas <dgcbueu@gmail.com> (cherry picked from commit 6cb3328b4fd4939f3800d4be9d52744b753de1b6)
Diffstat (limited to 'target/linux/bmips/image/bcm6328.mk')
-rw-r--r--target/linux/bmips/image/bcm6328.mk13
1 files changed, 13 insertions, 0 deletions
diff --git a/target/linux/bmips/image/bcm6328.mk b/target/linux/bmips/image/bcm6328.mk
index ef74410f1e..8023ef8fa1 100644
--- a/target/linux/bmips/image/bcm6328.mk
+++ b/target/linux/bmips/image/bcm6328.mk
@@ -26,6 +26,19 @@ define Device/comtrend_ar-5387un
endef
TARGET_DEVICES += comtrend_ar-5387un
+define Device/nucom_r5010unv2
+ $(Device/bcm63xx-cfe)
+ DEVICE_VENDOR := NuCom
+ DEVICE_MODEL := R5010UNv2
+ CHIP_ID := 6328
+ CFE_BOARD_ID := 96328ang
+ FLASH_MB := 16
+ DEVICE_PACKAGES += $(USB2_PACKAGES) \
+ $(B43_PACKAGES) broadcom-43217-sprom \
+ kmod-leds-bcm6328
+endef
+TARGET_DEVICES += nucom_r5010unv2
+
define Device/sercomm_ad1018
$(Device/sercomm-nand)
DEVICE_VENDOR := Sercomm