aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bmips/image/bcm6328.mk
diff options
context:
space:
mode:
authorÁlvaro Fernández Rojas <noltari@gmail.com>2023-06-11 18:44:36 +0200
committerÁlvaro Fernández Rojas <noltari@gmail.com>2023-06-12 18:54:42 +0200
commit8f1251a95150b0e30d8a07521c8d4b5e1f6a7a7e (patch)
tree4eb36041a34108438d791f780f6b20752c143d2f /target/linux/bmips/image/bcm6328.mk
parentf3ec4a2790a4f1bdde2f745d0cb319260c8cee49 (diff)
downloadupstream-8f1251a95150b0e30d8a07521c8d4b5e1f6a7a7e.tar.gz
upstream-8f1251a95150b0e30d8a07521c8d4b5e1f6a7a7e.tar.bz2
upstream-8f1251a95150b0e30d8a07521c8d4b5e1f6a7a7e.zip
bmips: add support for Comtrend AR-5381u
The Comtrend AR-5381u is a wifi fast ethernet router, 2.4 GHz single band with two internal antennas. Hardware: - SoC: Broadcom BCM6328 - CPU: single core BMIPS4350 @ 320Mhz - RAM: 64 MB DDR - Flash: 16 MB SPI NOR - Ethernet LAN: 4x 100Mbit - Wifi 2.4 GHz: miniPCI Broadcom BCM43225 802.11bgn - USB: 1x 2.0 - Buttons: 1x (reset) - LEDs: yes - UART: yes Installation via CFE web UI: 1. Power off the router. 2. Press reset button near the power switch. 3. Keep it pressed while powering up during ~20+ seconds. 4. Browse to http://192.168.1.1 and upload the firmware. 5. Wait a few minutes for it to finish. Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com> (cherry picked from commit bcdf861519)
Diffstat (limited to 'target/linux/bmips/image/bcm6328.mk')
-rw-r--r--target/linux/bmips/image/bcm6328.mk13
1 files changed, 13 insertions, 0 deletions
diff --git a/target/linux/bmips/image/bcm6328.mk b/target/linux/bmips/image/bcm6328.mk
index b3cef51a71..dfa134df94 100644
--- a/target/linux/bmips/image/bcm6328.mk
+++ b/target/linux/bmips/image/bcm6328.mk
@@ -1,5 +1,18 @@
# SPDX-License-Identifier: GPL-2.0-or-later
+define Device/comtrend_ar-5381u
+ $(Device/bcm63xx-cfe)
+ DEVICE_VENDOR := Comtrend
+ DEVICE_MODEL := AR-5381u
+ CHIP_ID := 6328
+ CFE_BOARD_ID := 96328A-1241N
+ FLASH_MB := 16
+ DEVICE_PACKAGES += $(USB2_PACKAGES) \
+ $(B43_PACKAGES) broadcom-43225-sprom \
+ kmod-leds-bcm6328
+endef
+TARGET_DEVICES += comtrend_ar-5381u
+
define Device/comtrend_ar-5387un
$(Device/bcm63xx-cfe)
DEVICE_VENDOR := Comtrend