aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bmips/image/bcm6328.mk
diff options
context:
space:
mode:
authorÁlvaro Fernández Rojas <noltari@gmail.com>2023-04-09 21:01:11 +0200
committerÁlvaro Fernández Rojas <noltari@gmail.com>2023-04-10 10:04:08 +0200
commit6fd8e0f943a0e8216daf238e015b6a311512d4ae (patch)
treefccae96552a7fbdcb5b66535c57ad3892a4a8ab5 /target/linux/bmips/image/bcm6328.mk
parente76556d967fac9e25ca49298996aeea491c9ef90 (diff)
downloadupstream-6fd8e0f943a0e8216daf238e015b6a311512d4ae.tar.gz
upstream-6fd8e0f943a0e8216daf238e015b6a311512d4ae.tar.bz2
upstream-6fd8e0f943a0e8216daf238e015b6a311512d4ae.zip
bmips: add subtargets for each SoC
BMIPS is a generic arch that can be used for multiple Broadcom SoCs, each one with its own specific drivers, so instead of having a huge kernel supporting all of them, let's switch to a subtarget per SoC like other OpenWrt targets. Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
Diffstat (limited to 'target/linux/bmips/image/bcm6328.mk')
-rw-r--r--target/linux/bmips/image/bcm6328.mk13
1 files changed, 13 insertions, 0 deletions
diff --git a/target/linux/bmips/image/bcm6328.mk b/target/linux/bmips/image/bcm6328.mk
new file mode 100644
index 0000000000..3a739a7e71
--- /dev/null
+++ b/target/linux/bmips/image/bcm6328.mk
@@ -0,0 +1,13 @@
+# SPDX-License-Identifier: GPL-2.0-or-later
+
+define Device/comtrend_ar-5387un
+ $(Device/bcm63xx-cfe)
+ DEVICE_VENDOR := Comtrend
+ DEVICE_MODEL := AR-5387un
+ CHIP_ID := 6328
+ CFE_BOARD_ID := 96328A-1441N1
+ FLASH_MB := 16
+ DEVICE_PACKAGES += $(USB2_PACKAGES) $(B43_PACKAGES) \
+ kmod-leds-bcm6328
+endef
+TARGET_DEVICES += comtrend_ar-5387un