aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bmips/image/bcm6328.mk
diff options
context:
space:
mode:
authorÁlvaro Fernández Rojas <noltari@gmail.com>2023-06-12 19:51:22 +0200
committerÁlvaro Fernández Rojas <noltari@gmail.com>2023-06-15 20:58:16 +0200
commit3d66e7f1db70c98876ea6e9aeb57622d6d30c5e8 (patch)
tree35f33a9f4a369e8561de2209c3f70d3559e082e7 /target/linux/bmips/image/bcm6328.mk
parentb8bbe0d8006f086ab90ec0d304a4d1afdf91b1cb (diff)
downloadupstream-3d66e7f1db70c98876ea6e9aeb57622d6d30c5e8.tar.gz
upstream-3d66e7f1db70c98876ea6e9aeb57622d6d30c5e8.tar.bz2
upstream-3d66e7f1db70c98876ea6e9aeb57622d6d30c5e8.zip
bmips: add support for Sercomm AD1018
The Sercomm AD1018 is a wifi fast ethernet router, 2.4 GHz single band with two internal antennas. Hardware: - SoC: Broadcom BCM6328 - CPU: single core BMIPS4350 @ 320Mhz - RAM: 64 MB (v1) / 128 MB (v2) DDR - Flash: 128 MB NAND - Ethernet LAN: 4x 100Mbit - Wifi 2.4 GHz: miniPCI Broadcom BCM43217 802.11bgn - USB: 1x 2.0 - Buttons: 3x (reset) - LEDs: yes - UART: yes Installation via OEM web UI: 1. Use the admin credentials to login via web UI 2. Go to Managament->Update firmware and select the OpenWrt CFE firmware 3. Press "Update Firmware" button and wait some minutes until it finish Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com> (cherry picked from commit 38ebb2eafde604ff6d9b0021d1d21208070a2d09)
Diffstat (limited to 'target/linux/bmips/image/bcm6328.mk')
-rw-r--r--target/linux/bmips/image/bcm6328.mk18
1 files changed, 18 insertions, 0 deletions
diff --git a/target/linux/bmips/image/bcm6328.mk b/target/linux/bmips/image/bcm6328.mk
index dfa134df94..ef74410f1e 100644
--- a/target/linux/bmips/image/bcm6328.mk
+++ b/target/linux/bmips/image/bcm6328.mk
@@ -25,3 +25,21 @@ define Device/comtrend_ar-5387un
kmod-leds-bcm6328
endef
TARGET_DEVICES += comtrend_ar-5387un
+
+define Device/sercomm_ad1018
+ $(Device/sercomm-nand)
+ DEVICE_VENDOR := Sercomm
+ DEVICE_MODEL := AD1018
+ CHIP_ID := 6328
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ SUBPAGESIZE := 512
+ VID_HDR_OFFSET := 2048
+ DEVICE_PACKAGES += $(USB2_PACKAGES) \
+ $(B43_PACKAGES) broadcom-43217-sprom \
+ kmod-leds-bcm6328
+ SERCOMM_FSVER := 1001
+ SERCOMM_HWVER := 1415153
+ SERCOMM_SWVER := 3013
+endef
+TARGET_DEVICES += sercomm_ad1018