aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/patches-5.15/440-mtd-ar934x-nand-driver.patch
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2022-03-27 23:12:39 +0200
committerDavid Bauer <mail@david-bauer.net>2022-03-30 17:28:39 +0200
commit9a0155bc4fa3642cdf930d50098bc929173f170f (patch)
tree3e1387b63be3e1fc8124d5b447d35b1d6273fcc7 /target/linux/ath79/patches-5.15/440-mtd-ar934x-nand-driver.patch
parentfc94c0d203d1c97d3dfdd045fb57b1cb7826e491 (diff)
downloadupstream-9a0155bc4fa3642cdf930d50098bc929173f170f.tar.gz
upstream-9a0155bc4fa3642cdf930d50098bc929173f170f.tar.bz2
upstream-9a0155bc4fa3642cdf930d50098bc929173f170f.zip
ath79: add 5.15 support for generic subtarget
Add Kernel 5.15 patches + config. This is currently only available for the generic subtarget, as it was exclusively tested with this target. Tested-on: Siemens WS-AP3610, Enterasys WS-AP3705i Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'target/linux/ath79/patches-5.15/440-mtd-ar934x-nand-driver.patch')
-rw-r--r--target/linux/ath79/patches-5.15/440-mtd-ar934x-nand-driver.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/ath79/patches-5.15/440-mtd-ar934x-nand-driver.patch b/target/linux/ath79/patches-5.15/440-mtd-ar934x-nand-driver.patch
new file mode 100644
index 0000000000..3ce64aa51d
--- /dev/null
+++ b/target/linux/ath79/patches-5.15/440-mtd-ar934x-nand-driver.patch
@@ -0,0 +1,25 @@
+--- a/drivers/mtd/nand/raw/Kconfig
++++ b/drivers/mtd/nand/raw/Kconfig
+@@ -555,4 +555,12 @@ config MTD_NAND_DISKONCHIP_BBTWRITE
+ load time (assuming you build diskonchip as a module) with the module
+ parameter "inftl_bbt_write=1".
+
++config MTD_NAND_AR934X
++ tristate "Support for NAND controller on Qualcomm Atheros AR934x/QCA955x SoCs"
++ depends on ATH79 || COMPILE_TEST
++ depends on HAS_IOMEM
++ help
++ Enables support for NAND controller on Qualcomm Atheros SoCs.
++ This controller is found on AR934x and QCA955x SoCs.
++
+ endif # MTD_RAW_NAND
+--- a/drivers/mtd/nand/raw/Makefile
++++ b/drivers/mtd/nand/raw/Makefile
+@@ -58,6 +58,7 @@ obj-$(CONFIG_MTD_NAND_ARASAN) += arasan
+ obj-$(CONFIG_MTD_NAND_INTEL_LGM) += intel-nand-controller.o
+ obj-$(CONFIG_MTD_NAND_ROCKCHIP) += rockchip-nand-controller.o
+ obj-$(CONFIG_MTD_NAND_PL35X) += pl35x-nand-controller.o
++obj-$(CONFIG_MTD_NAND_AR934X) += ar934x_nand.o
+
+ nand-objs := nand_base.o nand_legacy.o nand_bbt.o nand_timings.o nand_ids.o
+ nand-objs += nand_onfi.o