aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/patches-5.15/404-mtd-cybertan-trx-parser.patch
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2022-03-27 23:12:39 +0200
committerDavid Bauer <mail@david-bauer.net>2022-03-30 17:28:39 +0200
commit9a0155bc4fa3642cdf930d50098bc929173f170f (patch)
tree3e1387b63be3e1fc8124d5b447d35b1d6273fcc7 /target/linux/ath79/patches-5.15/404-mtd-cybertan-trx-parser.patch
parentfc94c0d203d1c97d3dfdd045fb57b1cb7826e491 (diff)
downloadupstream-9a0155bc4fa3642cdf930d50098bc929173f170f.tar.gz
upstream-9a0155bc4fa3642cdf930d50098bc929173f170f.tar.bz2
upstream-9a0155bc4fa3642cdf930d50098bc929173f170f.zip
ath79: add 5.15 support for generic subtarget
Add Kernel 5.15 patches + config. This is currently only available for the generic subtarget, as it was exclusively tested with this target. Tested-on: Siemens WS-AP3610, Enterasys WS-AP3705i Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'target/linux/ath79/patches-5.15/404-mtd-cybertan-trx-parser.patch')
-rw-r--r--target/linux/ath79/patches-5.15/404-mtd-cybertan-trx-parser.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/target/linux/ath79/patches-5.15/404-mtd-cybertan-trx-parser.patch b/target/linux/ath79/patches-5.15/404-mtd-cybertan-trx-parser.patch
new file mode 100644
index 0000000000..923589661e
--- /dev/null
+++ b/target/linux/ath79/patches-5.15/404-mtd-cybertan-trx-parser.patch
@@ -0,0 +1,27 @@
+--- a/drivers/mtd/parsers/Makefile
++++ b/drivers/mtd/parsers/Makefile
+@@ -8,6 +8,7 @@ obj-$(CONFIG_MTD_OF_PARTS) += ofpart.o
+ ofpart-y += ofpart_core.o
+ ofpart-$(CONFIG_MTD_OF_PARTS_BCM4908) += ofpart_bcm4908.o
+ ofpart-$(CONFIG_MTD_OF_PARTS_LINKSYS_NS)+= ofpart_linksys_ns.o
++obj-$(CONFIG_MTD_PARSER_CYBERTAN) += parser_cybertan.o
+ obj-$(CONFIG_MTD_PARSER_IMAGETAG) += parser_imagetag.o
+ obj-$(CONFIG_MTD_AFS_PARTS) += afs.o
+ obj-$(CONFIG_MTD_PARSER_TRX) += parser_trx.o
+--- a/drivers/mtd/parsers/Kconfig
++++ b/drivers/mtd/parsers/Kconfig
+@@ -102,6 +102,14 @@ config MTD_OF_PARTS_LINKSYS_NS
+ two "firmware" partitions. Currently used firmware has to be detected
+ using CFE environment variable.
+
++config MTD_PARSER_CYBERTAN
++ tristate "Parser for Cybertan format partitions"
++ depends on MTD && (ATH79 || COMPILE_TEST)
++ help
++ Cybertan has a proprietory header than encompasses a Broadcom trx
++ header. This driver will parse the header and take care of the
++ special offsets that result in the extra headers.
++
+ config MTD_PARSER_IMAGETAG
+ tristate "Parser for BCM963XX Image Tag format partitions"
+ depends on BCM63XX || BMIPS_GENERIC || COMPILE_TEST