aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image
diff options
context:
space:
mode:
authorMichał Kępień <openwrt@kempniu.pl>2023-04-18 15:48:41 +0200
committerPetr Štetiar <ynezz@true.cz>2023-05-16 14:55:18 +0200
commit95577e7bd108b5c70e5c757ce5b73545e068b8d6 (patch)
tree27bf4fe5cc3b4b1cf5131610583d6fe7e87a64ed /target/linux/ath79/image
parent6b17e19ad8560151f399afb7b10ea44315865f69 (diff)
downloadupstream-95577e7bd108b5c70e5c757ce5b73545e068b8d6.tar.gz
upstream-95577e7bd108b5c70e5c757ce5b73545e068b8d6.tar.bz2
upstream-95577e7bd108b5c70e5c757ce5b73545e068b8d6.zip
ath79: add support for MikroTik RB951Ui-2HnD
MikroTik RB951Ui-2HnD is a wireless SOHO router that was previously supported by the ar71xx target, see commit d19b868b12 ("ar71xx: Add support for MikroTik RB951Ui-2HnD"). Specifications -------------- - SoC: Atheros AR9344 (600 MHz) - RAM: 128 MB (2x 64 MB) - Storage: 128 MB NAND flash (various manufacturers) - Ethernet: Atheros AR8229 switch, 5x 10/100 Mbit/s - 1x PoE in (port 1, 8-30 V input) - 1x PoE out (port 5, 500 mA output) - Wireless: Atheros AR9340 (802.11b/g/n) - USB: 2.0 (1A) - 9x LED: - 1x power (green, not configurable) - 1x user (green) - 5x FE ports (green) - 1x wireless (green) - 1x PoE out (red) - 1x button (restart) See https://mikrotik.com/product/RB951Ui-2HnD for more details. Flashing -------- TFTP boot initramfs image and then perform sysupgrade. Follow common MikroTik procedures at https://openwrt.org/toh/mikrotik/common. Signed-off-by: Michał Kępień <openwrt@kempniu.pl>
Diffstat (limited to 'target/linux/ath79/image')
-rw-r--r--target/linux/ath79/image/mikrotik.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/ath79/image/mikrotik.mk b/target/linux/ath79/image/mikrotik.mk
index fb0035fb65..3f65b35c8c 100644
--- a/target/linux/ath79/image/mikrotik.mk
+++ b/target/linux/ath79/image/mikrotik.mk
@@ -48,6 +48,15 @@ define Device/mikrotik_routerboard-922uags-5hpacd
endef
TARGET_DEVICES += mikrotik_routerboard-922uags-5hpacd
+define Device/mikrotik_routerboard-951ui-2hnd
+ $(Device/mikrotik_nand)
+ SOC := ar9344
+ DEVICE_MODEL := RouterBOARD 951Ui-2HnD
+ DEVICE_PACKAGES += kmod-usb-ohci kmod-usb2
+ SUPPORTED_DEVICES += rb-951ui-2hnd
+endef
+TARGET_DEVICES += mikrotik_routerboard-951ui-2hnd
+
define Device/mikrotik_routerboard-951ui-2nd
$(Device/mikrotik_nor)
SOC := qca9531