aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image
diff options
context:
space:
mode:
authorAndreas Böhler <dev@aboehler.at>2023-04-29 20:48:47 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2023-05-06 20:59:46 +0200
commit590d1fd0e636f627bbfeb988909ec36cc5450a3b (patch)
treecb54b71f67d1f88d151b2b7ba13a57a6850c2034 /target/linux/ath79/image
parent8bc4aaf45cee578f6e527b1582d0dcf065dc81c8 (diff)
downloadupstream-590d1fd0e636f627bbfeb988909ec36cc5450a3b.tar.gz
upstream-590d1fd0e636f627bbfeb988909ec36cc5450a3b.tar.bz2
upstream-590d1fd0e636f627bbfeb988909ec36cc5450a3b.zip
ath79: add support for ZTE MF282
The ZTE MF282 is a LTE router used (exclusively?) by the network operator "3". Specifications ============== SoC: QCA9563 (775MHz) RAM: 128MiB Flash: 8MiB SPI-NOR + 128MiB SPI-NAND LAN: 1x GBit LAN LTE: ZTE MF270 (Cat4), detected as P685M WiFi: QCA9880ac + QCA9560bgn MAC addresses ============= LAN: from config WiFi 1: from config WiFi 2: +1 Installation ============ TFTP installation using UART is preferred. Disassemble the device and connect serial. Put the initramfs image as openwrt.bin to your TFTP server and configure a static IP of 192.168.1.100. Load the initramfs image by typing: setenv serverip 192.168.1.100 setenv ipaddr 192.168.1.1 tftpboot 0x82000000 openwrt.bin bootm 0x82000000 From this intiramfs boot you can take a backup of the currently installed partitions as no vendor firmware is available for download. Once booted, transfer the sysupgrade image and run sysupgrade. LTE Modem ========= The LTE modem is probably the same as in the MF283+, all instructions apply. Configuring the connection using modemmanager works properly, the modem provides three serial ports and a QMI CDC ethernet interface. Signed-off-by: Andreas Böhler <dev@aboehler.at>
Diffstat (limited to 'target/linux/ath79/image')
-rw-r--r--target/linux/ath79/image/nand.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/ath79/image/nand.mk b/target/linux/ath79/image/nand.mk
index 40c57d8b06..10a5485010 100644
--- a/target/linux/ath79/image/nand.mk
+++ b/target/linux/ath79/image/nand.mk
@@ -390,6 +390,14 @@ define Device/zte_mf281
endef
TARGET_DEVICES += zte_mf281
+define Device/zte_mf282
+ $(Device/zte_mf28x_common)
+ DEVICE_MODEL := MF282
+ DEVICE_PACKAGES += ath10k-firmware-qca988x-ct kmod-usb-net-qmi-wwan \
+ kmod-usb-serial-option uqmi
+endef
+TARGET_DEVICES += zte_mf282
+
define Device/zte_mf286
$(Device/zte_mf28x_common)
DEVICE_MODEL := MF286