aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic.mk
diff options
context:
space:
mode:
authorAlbin Hellström <albin.hellstrom@gmail.com>2021-01-07 22:51:06 +0100
committerDavid Bauer <mail@david-bauer.net>2022-08-29 01:09:17 +0200
commitf8c87aa2d27ab405f284dd4357377ab5c893a345 (patch)
treeafdb09d483f9249e3634c6cb4b33cf5951c8bf89 /target/linux/ath79/image/generic.mk
parent314cad2cba0167d504ebad5792a7485fc181a865 (diff)
downloadupstream-f8c87aa2d27ab405f284dd4357377ab5c893a345.tar.gz
upstream-f8c87aa2d27ab405f284dd4357377ab5c893a345.tar.bz2
upstream-f8c87aa2d27ab405f284dd4357377ab5c893a345.zip
ath79: add support for Extreme Networks WS-AP3805i
Specifications: - SoC: Qualcomm Atheros QCA9557-AT4A - RAM: 2x 128MB Nanya NT5TU64M16HG - FLASH: 64MB - SPANSION FL512SAIFG1 - LAN: Atheros AR8035-A (RGMII GbE with PoE+ IN) - WLAN2: Qualcomm Atheros QCA9557 2x2 2T2R - WLAN5: Qualcomm Atheros QCA9882-BR4A 2x2 2T2R - SERIAL: UART pins at J10 (115200 8n1) Pinout is 3.3V - GND - TX - RX (Arrow Pad is 3.3V) - LEDs: Power (Green/Amber) WiFi 5 (Green) WiFi 2 (Green) - BTN: Reset Installation: 1. Download the OpenWrt initramfs-image. Place it into a TFTP server root directory and rename it to 1D01A8C0.img Configure the TFTP server to listen at 192.168.1.66/24. 2. Connect the TFTP server to the access point. 3. Connect to the serial console of the access point. Attach power and interrupt the boot procedure when prompted. Credentials are admin / new2day 4. Configure U-Boot for booting OpenWrt from ram and flash: $ setenv boot_openwrt 'setenv bootargs; bootm 0xa1280000' $ setenv ramboot_openwrt 'setenv serverip 192.168.1.66; tftpboot 0x89000000 1D01A8C0.img; bootm' $ setenv bootcmd 'run boot_openwrt' $ saveenv 5. Load OpenWrt into memory: $ run ramboot_openwrt 6. Transfer the OpenWrt sysupgrade image to the device. Write the image to flash using sysupgrade: $ sysupgrade -n /path/to/openwrt-sysupgrade.bin Signed-off-by: Albin Hellström <albin.hellstrom@gmail.com> [rename vendor - minor style fixes - update commit message] Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'target/linux/ath79/image/generic.mk')
-rw-r--r--target/linux/ath79/image/generic.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 575004ea15..d205fd8d9e 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -1278,6 +1278,16 @@ define Device/etactica_eg200
endef
TARGET_DEVICES += etactica_eg200
+define Device/extreme-networks_ws-ap3805i
+ SOC := qca9557
+ BLOCKSIZE := 256k
+ DEVICE_VENDOR := Extreme Networks
+ DEVICE_MODEL := WS-AP3805i
+ DEVICE_PACKAGES := ath10k-firmware-qca988x-ct kmod-ath10k-ct
+ IMAGE_SIZE := 29440k
+endef
+TARGET_DEVICES += extreme-networks_ws-ap3805i
+
define Device/glinet_6408
$(Device/tplink-8mlzma)
SOC := ar9331