aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic.mk
diff options
context:
space:
mode:
authorSebastian Schaper <openwrt@sebastianschaper.net>2021-03-28 00:33:45 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2022-08-21 00:09:53 +0200
commita6e0ca96da45067026f9c74ed1e0e16fc1cf7b7c (patch)
tree8435eda2a877f00278c95e8f4268b622660ac352 /target/linux/ath79/image/generic.mk
parent527be5a456cecdc4e3296816906e117ec04bfdff (diff)
downloadupstream-a6e0ca96da45067026f9c74ed1e0e16fc1cf7b7c.tar.gz
upstream-a6e0ca96da45067026f9c74ed1e0e16fc1cf7b7c.tar.bz2
upstream-a6e0ca96da45067026f9c74ed1e0e16fc1cf7b7c.zip
ath79: add support for ZyXEL NWA1123-AC
Specifications: * AR9342, 16 MiB Flash, 64 MiB RAM, 802.11n 2T2R, 2.4 GHz * QCA9882 PCIe card, 802.11ac 2T2R * 1x Gigabit Ethernet (AR8035), 802.3af PoE Installation: * OEM Web UI is at 192.168.1.2 login as `admin` with password `1234` * Flash factory-AAOX.bin The string `AAOX` needs to be present within the file name of the uploaded image to be accepted by the OEM Web-based updater, the factory image is named accordingly to save the user from the hassle of manual renaming. TFTP Recovery: * Open the case, connect to TTL UART port (this is the official method described by Zyxel, the reset button is useless during power-on) * Extract factory image (.tar.bz2), serve `vmlinux_mi124_f1e.lzma.uImage` and `mi124_f1e-jffs2` via tftp at 192.168.1.10 * Interrupt uboot countdown, execute commands `run lk` `run lf` to flash the kernel / filesystem accordingly MAC addresses as verified by OEM firmware: use address source LAN *:1c mib0 0x30 ('eth0mac'), art 0x1002 (label) 2g *:1c mib0 0x4b ('wifi0mac') 5g *:1e mib0 0x66 ('wifi1mac') Signed-off-by: Sebastian Schaper <openwrt@sebastianschaper.net>
Diffstat (limited to 'target/linux/ath79/image/generic.mk')
-rw-r--r--target/linux/ath79/image/generic.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 617f1eed30..612b79f8d6 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -2716,6 +2716,16 @@ define Device/zyxel_nwa1121-ni
endef
TARGET_DEVICES += zyxel_nwa1121-ni
+define Device/zyxel_nwa1123-ac
+ $(Device/zyxel_nwa11xx)
+ DEVICE_MODEL := NWA1123
+ DEVICE_VARIANT := AC
+ ZYXEL_MODEL_STRING := AAOX
+ DEVICE_PACKAGES := kmod-ath10k-ct-smallbuffers \
+ ath10k-firmware-qca988x-ct
+endef
+TARGET_DEVICES += zyxel_nwa1123-ac
+
define Device/zyxel_nwa1123-ni
$(Device/zyxel_nwa11xx)
DEVICE_MODEL := NWA1123