aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic.mk
diff options
context:
space:
mode:
authorSebastian Schaper <openwrt@sebastianschaper.net>2022-08-07 00:59:06 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2022-08-21 00:09:53 +0200
commita434795809bb0759947f57117a28cd0df5e19e76 (patch)
tree84dff2a874f71b126a9ac4113407e69de0c397fe /target/linux/ath79/image/generic.mk
parenta6e0ca96da45067026f9c74ed1e0e16fc1cf7b7c (diff)
downloadupstream-a434795809bb0759947f57117a28cd0df5e19e76.tar.gz
upstream-a434795809bb0759947f57117a28cd0df5e19e76.tar.bz2
upstream-a434795809bb0759947f57117a28cd0df5e19e76.zip
ath79: add support for ZyXEL NWA1100-NH
Specifications: * AR9342, 16 MiB Flash, 64 MiB RAM, 802.11n 2T2R, 2.4 GHz * 1x Gigabit Ethernet (AR8035), 802.3af PoE Installation: * OEM Web UI is at 192.168.1.2 login as `admin` with password `1234` * Flash factory-AASI.bin The string `AASI` needs to be present within the file name of the uploaded image to be accepted by the OEM Web-based updater, the factory image is named accordingly to save the user from the hassle of manual renaming. TFTP Recovery: * Open the case, connect to TTL UART port (this is the official method described by Zyxel, the reset button is useless during power-on) * Extract factory image (.tar.bz2), serve `vmlinux_mi124_f1e.lzma.uImage` and `mi124_f1e-jffs2` via tftp at 192.168.1.10 * Interrupt uboot countdown, execute commands `run lk` `run lf` to flash the kernel / filesystem accordingly MAC addresses as verified by OEM firmware: use address source LAN *:cc mib0 0x30 ('eth0mac'), art 0x1002 (label) 2g *:cd mib0 0x4b ('wifi0mac') Signed-off-by: Sebastian Schaper <openwrt@sebastianschaper.net>
Diffstat (limited to 'target/linux/ath79/image/generic.mk')
-rw-r--r--target/linux/ath79/image/generic.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 612b79f8d6..575004ea15 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -2708,6 +2708,14 @@ define Device/zyxel_nwa11xx
vmlinux_mi124_f1e mi124_f1e-jffs2 | append-md5sum-bin
endef
+define Device/zyxel_nwa1100-nh
+ $(Device/zyxel_nwa11xx)
+ DEVICE_MODEL := NWA1100
+ DEVICE_VARIANT := NH
+ ZYXEL_MODEL_STRING := AASI
+endef
+TARGET_DEVICES += zyxel_nwa1100-nh
+
define Device/zyxel_nwa1121-ni
$(Device/zyxel_nwa11xx)
DEVICE_MODEL := NWA1121