aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic.mk
diff options
context:
space:
mode:
authorTomasz Maciej Nowak <tmn505@gmail.com>2022-06-07 15:58:30 +0200
committerChristian Lamparter <chunkeey@gmail.com>2022-06-24 17:10:24 +0200
commit9decd2a8436d2bb6b5f436268c92a6e6728486ce (patch)
tree20cc385ba88496301d6375a0c3547a0ac42a860a /target/linux/ath79/image/generic.mk
parentb52719b71a3337e5ae840c7a50fe41ebdc070f4e (diff)
downloadupstream-9decd2a8436d2bb6b5f436268c92a6e6728486ce.tar.gz
upstream-9decd2a8436d2bb6b5f436268c92a6e6728486ce.tar.bz2
upstream-9decd2a8436d2bb6b5f436268c92a6e6728486ce.zip
ath79: bsap18x0: pad rootfs image
This image is supposed to be written with help of bootloader to the flash, but as it stands, it's not aligned to block size and RedBoot will happily create non-aligned partition size in FIS directory. This could lead to kernel to mark the partition as read-only, therefore pad the image to block erase size boundary. Signed-off-by: Tomasz Maciej Nowak <tmn505@gmail.com>
Diffstat (limited to 'target/linux/ath79/image/generic.mk')
-rw-r--r--target/linux/ath79/image/generic.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 96b073b1b5..effa3af841 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -209,7 +209,7 @@ define Device/adtran_bsap1880
IMAGE_SIZE := 11200k
IMAGES += kernel.bin rootfs.bin
IMAGE/kernel.bin := append-kernel
- IMAGE/rootfs.bin := append-rootfs | pad-rootfs
+ IMAGE/rootfs.bin := append-rootfs | pad-rootfs | pad-to $$(BLOCKSIZE)
IMAGE/sysupgrade.bin := append-rootfs | pad-rootfs | \
check-size | sysupgrade-tar rootfs=$$$$@ | append-metadata
endef