aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic.mk
diff options
context:
space:
mode:
authorTamas Balogh <tamasbalogh@hotmail.com>2022-06-28 12:35:05 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2022-06-30 00:23:42 +0200
commit416d4483e878fe316ba490c3948850c0aee0b828 (patch)
treeb9f90552ff953d3393af79611ba0075ec65c30b5 /target/linux/ath79/image/generic.mk
parente1dcaeb55c939365cdd27e469b63fca295bf1a2e (diff)
downloadupstream-416d4483e878fe316ba490c3948850c0aee0b828.tar.gz
upstream-416d4483e878fe316ba490c3948850c0aee0b828.tar.bz2
upstream-416d4483e878fe316ba490c3948850c0aee0b828.zip
ath79: add support for ASUS RP-AC51
Asus RP-AC51 Repeater Category: AC750 300+433 (OEM w. unstable driver) AC1200 300+866 (OpenWrt w. stable driver) Hardware specifications: Board: AP147 SoC: QCA9531 2.4G b/g/n WiFi: QCA9886 5G n/ac DRAM: 128MB DDR2 Flash: gd25q128 16MB SPI-NOR LAN/WAN: AR8229 1x100M Clocks: CPU:650MHz, DDR:600MHz, AHB:200MHz MAC addresses as verified by OEM firmware: use address source Lan/W2G *:C8 art 0x1002 (label) 5G *:CC art 0x5006 Installation: Asus windows recovery tool: install the Asus firmware restoration utility unplug the router, hold the reset button while powering it on release when the power LED flashes slowly specify a static IP on your computer: IP address: 192.168.1.75 Subnet mask 255.255.255.0 Start the Asus firmware restoration utility, specify the factory image and press upload Do not power off the device after OpenWrt has booted until the LED flashing. TFTP Recovery method: set computer to a static ip, 192.168.1.10 connect computer to the LAN 1 port of the router hold the reset button while powering on the router for a few seconds send firmware image using a tftp client; i.e from linux: $ tftp tftp> binary tftp> connect 192.168.1.1 tftp> put factory.bin tftp> quit Signed-off-by: Tamas Balogh <tamasbalogh@hotmail.com>
Diffstat (limited to 'target/linux/ath79/image/generic.mk')
-rw-r--r--target/linux/ath79/image/generic.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 6fc844b4b2..8d059f3679 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -389,6 +389,17 @@ define Device/asus_pl-ac56
endef
TARGET_DEVICES += asus_pl-ac56
+define Device/asus_rp-ac51
+ SOC := qca9531
+ DEVICE_VENDOR := ASUS
+ DEVICE_MODEL := RP-AC51
+ IMAGE_SIZE := 16000k
+ IMAGES += factory.bin
+ DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca9888-ct \
+ -swconfig
+endef
+TARGET_DEVICES += asus_rp-ac51
+
define Device/asus_rp-ac66
SOC := qca9563
DEVICE_VENDOR := ASUS