aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic.mk
diff options
context:
space:
mode:
authorSebastian Schaper <openwrt@sebastianschaper.net>2020-09-09 20:42:53 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2022-08-21 00:09:53 +0200
commit251ecfe37914919422d74dd32fab15a86f65e879 (patch)
tree5f147ce402f6750b3df709891f7f58634e38810d /target/linux/ath79/image/generic.mk
parent3b2f19271cc2cd92a4f3c184f6362c2ec2793041 (diff)
downloadupstream-251ecfe37914919422d74dd32fab15a86f65e879.tar.gz
upstream-251ecfe37914919422d74dd32fab15a86f65e879.tar.bz2
upstream-251ecfe37914919422d74dd32fab15a86f65e879.zip
ath79: add support for ZyXEL NWA1121-NI
Specifications: * AR9342, 16 MiB Flash, 64 MiB RAM, 802.11n 2T2R, 2.4 GHz * 1x Gigabit Ethernet (AR8035), 802.3af PoE Installation: * OEM Web UI is at 192.168.1.2 login as `admin` with password `1234` * Flash factory-AABJ.bin The string `AABJ` needs to be present within the file name of the uploaded image to be accepted by the OEM Web-based updater, the factory image is named accordingly to save the user from the hassle of manual renaming. TFTP Recovery: * Open the case, connect to TTL UART port (this is the official method described by Zyxel, the reset button is useless during power-on) * Extract factory image (.tar.bz2), serve `vmlinux_mi124_f1e.lzma.uImage` and `mi124_f1e-jffs2` via tftp at 192.168.1.10 * Interrupt uboot countdown, execute commands `run lk` `run lf` to flash the kernel / filesystem accordingly MAC addresses as verified by OEM firmware: use address source LAN *:cc mib0 0x30 ('eth0mac'), art 0x1002 (label) 2g *:cd mib0 0x4b ('wifi0mac') Signed-off-by: Sebastian Schaper <openwrt@sebastianschaper.net>
Diffstat (limited to 'target/linux/ath79/image/generic.mk')
-rw-r--r--target/linux/ath79/image/generic.mk31
1 files changed, 30 insertions, 1 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 4aa6ed6480..9ba5e20e57 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -9,7 +9,7 @@ DEVICE_VARS += ADDPATTERN_ID ADDPATTERN_VERSION
DEVICE_VARS += SEAMA_SIGNATURE SEAMA_MTDBLOCK
DEVICE_VARS += KERNEL_INITRAMFS_PREFIX DAP_SIGNATURE
DEVICE_VARS += EDIMAX_HEADER_MAGIC EDIMAX_HEADER_MODEL
-DEVICE_VARS += OPENMESH_CE_TYPE
+DEVICE_VARS += OPENMESH_CE_TYPE ZYXEL_MODEL_STRING
define Build/add-elecom-factory-initramfs
$(eval edimax_model=$(word 1,$(1)))
@@ -161,6 +161,13 @@ define Build/wrgg-pad-rootfs
$(STAGING_DIR_HOST)/bin/padjffs2 $(IMAGE_ROOTFS) -c 64 >>$@
endef
+define Build/zyxel-tar-bz2
+ mkdir -p $@.tmp
+ mv $@ $@.tmp/$(word 2,$(1))
+ cp $(KDIR)/loader-$(DEVICE_NAME).uImage $@.tmp/$(word 1,$(1)).lzma.uImage
+ $(TAR) -cjf $@ -C $@.tmp .
+ rm -rf $@.tmp
+endef
define Device/seama
KERNEL := kernel-bin | append-dtb | relocate-kernel | lzma
@@ -2687,6 +2694,28 @@ define Device/zbtlink_zbt-wd323
endef
TARGET_DEVICES += zbtlink_zbt-wd323
+define Device/zyxel_nwa11xx
+ $(Device/loader-okli-uimage)
+ SOC := ar9342
+ DEVICE_VENDOR := ZyXEL
+ LOADER_FLASH_OFFS := 0x050000
+ KERNEL := kernel-bin | append-dtb | lzma | uImage lzma -M 0x4f4b4c49
+ IMAGE_SIZE := 8192k
+ IMAGES += factory-$$$$(ZYXEL_MODEL_STRING).bin
+ IMAGE/factory-$$$$(ZYXEL_MODEL_STRING).bin := \
+ append-kernel | pad-to $$$$(BLOCKSIZE) | append-rootfs | \
+ pad-rootfs | pad-to 8192k | check-size | zyxel-tar-bz2 \
+ vmlinux_mi124_f1e mi124_f1e-jffs2 | append-md5sum-bin
+endef
+
+define Device/zyxel_nwa1121-ni
+ $(Device/zyxel_nwa11xx)
+ DEVICE_MODEL := NWA1121
+ DEVICE_VARIANT := NI
+ ZYXEL_MODEL_STRING := AABJ
+endef
+TARGET_DEVICES += zyxel_nwa1121-ni
+
define Device/zyxel_nbg6616
SOC := qca9557
DEVICE_VENDOR := ZyXEL