aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/armvirt/image/Makefile
diff options
context:
space:
mode:
authorMathew McBride <matt@traverse.com.au>2022-07-15 02:38:02 +0000
committerPetr Štetiar <ynezz@true.cz>2023-06-13 14:12:34 +0200
commit2bec445c1d40f1d9a3d92708a99588cb83fcf272 (patch)
tree6cafa8364758d13da193b99dfa7af81442ab6adb /target/linux/armvirt/image/Makefile
parentf1a02ba135c388b3ff2400463c10f4f82584106b (diff)
downloadupstream-2bec445c1d40f1d9a3d92708a99588cb83fcf272.tar.gz
upstream-2bec445c1d40f1d9a3d92708a99588cb83fcf272.tar.bz2
upstream-2bec445c1d40f1d9a3d92708a99588cb83fcf272.zip
armvirt: 64: add support for other SystemReady-compatible vendors
These changes are to support other vendors that have SystemReady/EFI support, including: * Marvell Armada ** (This is speculative as I don't have a machine of my own to test) * Amazon Graviton (tested bare-metal and virtualized instances) * VMware (Fusion for ARM Mac preview) * NXP/Freescale (Layerscape series not already selected) * HiSilicon * Allwinner/sunxi * Rockchip (untested, options taken from arm64 defconfig) To give an idea of the hardware certified for SystemReady, see https://www.arm.com/architecture/system-architectures/systemready-certification-program/ir and https://www.arm.com/architecture/system-architectures/systemready-certification-program/es Other vendors that _should_ work include Marvell Octeon 10 and Ampere. I understand these systems should work "out of the box" in ACPI mode but may require other drivers (e.g PCIe NICs and storage controllers). Signed-off-by: Mathew McBride <matt@traverse.com.au> (23.05/5.15 version of c3151b6f04579a937b7cb166bbeff0d0ee539946)
Diffstat (limited to 'target/linux/armvirt/image/Makefile')
-rw-r--r--target/linux/armvirt/image/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/target/linux/armvirt/image/Makefile b/target/linux/armvirt/image/Makefile
index e88544c963..5a2004345c 100644
--- a/target/linux/armvirt/image/Makefile
+++ b/target/linux/armvirt/image/Makefile
@@ -107,7 +107,10 @@ define Device/generic
FILESYSTEMS := ext4 squashfs
DEVICE_PACKAGES += kmod-amazon-ena kmod-e1000e kmod-vmxnet3 kmod-rtc-rx8025 \
kmod-i2c-mux-pca954x kmod-gpio-pca953x partx-utils kmod-wdt-sp805 \
- kmod-fsl-dpaa2-net
+ kmod-mvneta kmod-mvpp2 kmod-fsl-dpaa1-net kmod-fsl-dpaa2-net \
+ kmod-fsl-enetc-net \
+ kmod-phy-aquantia kmod-phy-broadcom kmod-phy-marvell \
+ kmod-phy-marvell-10g kmod-atlantic
endef
TARGET_DEVICES += generic