aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-2.6.37/206-nxp-74hc153-gpio-chip-driver.patch
diff options
context:
space:
mode:
authorAlexandros C. Couloumbis <alex@ozo.com>2010-11-10 16:23:42 +0000
committerAlexandros C. Couloumbis <alex@ozo.com>2010-11-10 16:23:42 +0000
commit0c66bb9c5534b27bd4304ba4a65a3cc43fe77de5 (patch)
tree2b1fddffd4b343074e5d02e8aa267ece51e44cab /target/linux/ar71xx/patches-2.6.37/206-nxp-74hc153-gpio-chip-driver.patch
parentcec876fe24ae1883cf11d8a014238a95a618a2b6 (diff)
downloadupstream-0c66bb9c5534b27bd4304ba4a65a3cc43fe77de5.tar.gz
upstream-0c66bb9c5534b27bd4304ba4a65a3cc43fe77de5.tar.bz2
upstream-0c66bb9c5534b27bd4304ba4a65a3cc43fe77de5.zip
linux/ar71xx: add preliminary 2.6.37 kernel support
SVN-Revision: 23944
Diffstat (limited to 'target/linux/ar71xx/patches-2.6.37/206-nxp-74hc153-gpio-chip-driver.patch')
-rw-r--r--target/linux/ar71xx/patches-2.6.37/206-nxp-74hc153-gpio-chip-driver.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-2.6.37/206-nxp-74hc153-gpio-chip-driver.patch b/target/linux/ar71xx/patches-2.6.37/206-nxp-74hc153-gpio-chip-driver.patch
new file mode 100644
index 0000000000..394996ece7
--- /dev/null
+++ b/target/linux/ar71xx/patches-2.6.37/206-nxp-74hc153-gpio-chip-driver.patch
@@ -0,0 +1,25 @@
+--- a/drivers/gpio/Kconfig
++++ b/drivers/gpio/Kconfig
+@@ -401,4 +401,12 @@ config GPIO_JANZ_TTL
+ This driver provides support for driving the pins in output
+ mode only. Input mode is not supported.
+
++comment "Other GPIO expanders"
++
++config GPIO_NXP_74HC153
++ tristate "NXP 74HC153 Dual 4-input multiplexer"
++ help
++ Platform driver for NXP 74HC153 Dual 4-input Multiplexer. This
++ provides a GPIO interface supporting inputs.
++
+ endif
+--- a/drivers/gpio/Makefile
++++ b/drivers/gpio/Makefile
+@@ -18,6 +18,7 @@ obj-$(CONFIG_GPIO_MAX7301) += max7301.o
+ obj-$(CONFIG_GPIO_MAX732X) += max732x.o
+ obj-$(CONFIG_GPIO_MC33880) += mc33880.o
+ obj-$(CONFIG_GPIO_MCP23S08) += mcp23s08.o
++obj-$(CONFIG_GPIO_NXP_74HC153) += nxp_74hc153.o
+ obj-$(CONFIG_GPIO_74X164) += 74x164.o
+ obj-$(CONFIG_GPIO_PCA953X) += pca953x.o
+ obj-$(CONFIG_GPIO_PCF857X) += pcf857x.o