aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-2.6.35/205-wndr3700-usb-led-driver.patch
diff options
context:
space:
mode:
authorAlexandros C. Couloumbis <alex@ozo.com>2010-06-09 10:45:47 +0000
committerAlexandros C. Couloumbis <alex@ozo.com>2010-06-09 10:45:47 +0000
commitd45dc5e820b5589662236143a68928eaec01e83e (patch)
tree64a1434b436174e77545a6b7234612c5f0fdb3da /target/linux/ar71xx/patches-2.6.35/205-wndr3700-usb-led-driver.patch
parentbef7ceff095e5e648b45b4cf0c73fb7ad588b676 (diff)
downloadupstream-d45dc5e820b5589662236143a68928eaec01e83e.tar.gz
upstream-d45dc5e820b5589662236143a68928eaec01e83e.tar.bz2
upstream-d45dc5e820b5589662236143a68928eaec01e83e.zip
ar71xx: add kernel 2.6.35 preliminary support
SVN-Revision: 21734
Diffstat (limited to 'target/linux/ar71xx/patches-2.6.35/205-wndr3700-usb-led-driver.patch')
-rw-r--r--target/linux/ar71xx/patches-2.6.35/205-wndr3700-usb-led-driver.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-2.6.35/205-wndr3700-usb-led-driver.patch b/target/linux/ar71xx/patches-2.6.35/205-wndr3700-usb-led-driver.patch
new file mode 100644
index 0000000000..b289a85d46
--- /dev/null
+++ b/target/linux/ar71xx/patches-2.6.35/205-wndr3700-usb-led-driver.patch
@@ -0,0 +1,26 @@
+--- a/drivers/leds/Kconfig
++++ b/drivers/leds/Kconfig
+@@ -294,6 +294,13 @@ config LEDS_TRIGGERS
+
+ if LEDS_TRIGGERS
+
++config LEDS_WNDR3700_USB
++ tristate "NETGEAR WNDR3700 USB LED driver"
++ depends on LEDS_CLASS && AR71XX_MACH_WNDR3700
++ help
++ This option enables support for the USB LED found on the
++ NETGEAR WNDR3700 board.
++
+ comment "LED Triggers"
+
+ config LEDS_TRIGGER_TIMER
+--- a/drivers/leds/Makefile
++++ b/drivers/leds/Makefile
+@@ -30,6 +30,7 @@ obj-$(CONFIG_LEDS_DA903X) += leds-da903
+ obj-$(CONFIG_LEDS_WM831X_STATUS) += leds-wm831x-status.o
+ obj-$(CONFIG_LEDS_WM8350) += leds-wm8350.o
+ obj-$(CONFIG_LEDS_PWM) += leds-pwm.o
++obj-${CONFIG_LEDS_WNDR3700_USB} += leds-wndr3700-usb.o
+ obj-$(CONFIG_LEDS_REGULATOR) += leds-regulator.o
+ obj-$(CONFIG_LEDS_INTEL_SS4200) += leds-ss4200.o
+ obj-$(CONFIG_LEDS_LT3593) += leds-lt3593.o