aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches-2.6.36/007-adm5120_pci.patch
diff options
context:
space:
mode:
authorAlexandros C. Couloumbis <alex@ozo.com>2010-10-04 17:45:05 +0000
committerAlexandros C. Couloumbis <alex@ozo.com>2010-10-04 17:45:05 +0000
commit7cb70cb2b8f2b3e31d3e86576141abb161593fb6 (patch)
tree66996ea1e9ed75cda833e663a45805a1e804360d /target/linux/adm5120/patches-2.6.36/007-adm5120_pci.patch
parent8ae1a4fc69b0155cd30b7d39977f782c1046e477 (diff)
downloadupstream-7cb70cb2b8f2b3e31d3e86576141abb161593fb6.tar.gz
upstream-7cb70cb2b8f2b3e31d3e86576141abb161593fb6.tar.bz2
upstream-7cb70cb2b8f2b3e31d3e86576141abb161593fb6.zip
linux/adm5120: add preliminary 2.6.36 kernel support (refresh patches)
SVN-Revision: 23224
Diffstat (limited to 'target/linux/adm5120/patches-2.6.36/007-adm5120_pci.patch')
-rw-r--r--target/linux/adm5120/patches-2.6.36/007-adm5120_pci.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/adm5120/patches-2.6.36/007-adm5120_pci.patch b/target/linux/adm5120/patches-2.6.36/007-adm5120_pci.patch
new file mode 100644
index 0000000000..cb2a10c3ed
--- /dev/null
+++ b/target/linux/adm5120/patches-2.6.36/007-adm5120_pci.patch
@@ -0,0 +1,22 @@
+--- a/arch/mips/pci/Makefile
++++ b/arch/mips/pci/Makefile
+@@ -55,6 +55,7 @@ obj-$(CONFIG_ZAO_CAPCELLA) += fixup-capc
+ obj-$(CONFIG_WR_PPMC) += fixup-wrppmc.o
+ obj-$(CONFIG_MIKROTIK_RB532) += pci-rc32434.o ops-rc32434.o fixup-rc32434.o
+ obj-$(CONFIG_CPU_CAVIUM_OCTEON) += pci-octeon.o pcie-octeon.o
++obj-$(CONFIG_ADM5120) += pci-adm5120.o
+
+ ifdef CONFIG_PCI_MSI
+ obj-$(CONFIG_CPU_CAVIUM_OCTEON) += msi-octeon.o
+--- a/include/linux/pci_ids.h
++++ b/include/linux/pci_ids.h
+@@ -1759,6 +1759,9 @@
+ #define PCI_VENDOR_ID_ESDGMBH 0x12fe
+ #define PCI_DEVICE_ID_ESDGMBH_CPCIASIO4 0x0111
+
++#define PCI_VENDOR_ID_ADMTEK 0x1317
++#define PCI_DEVICE_ID_ADMTEK_ADM5120 0x5120
++
+ #define PCI_VENDOR_ID_SIIG 0x131f
+ #define PCI_SUBVENDOR_ID_SIIG 0x131f
+ #define PCI_DEVICE_ID_SIIG_1S_10x_550 0x1000