aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches-2.6.24/310-adm5120_wdt.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2008-01-30 15:25:48 +0000
committerGabor Juhos <juhosg@openwrt.org>2008-01-30 15:25:48 +0000
commit128bb0967a612a4359d29173f4d11a1716e5bf2a (patch)
treed4aa6c5844db9d0bef508776694aac64ebe22352 /target/linux/adm5120/patches-2.6.24/310-adm5120_wdt.patch
parent9bfca5ce18c5d02afc66a1c61fd85288d7af5d9e (diff)
downloadupstream-128bb0967a612a4359d29173f4d11a1716e5bf2a.tar.gz
upstream-128bb0967a612a4359d29173f4d11a1716e5bf2a.tar.bz2
upstream-128bb0967a612a4359d29173f4d11a1716e5bf2a.zip
add preliminary support for 2.6.24
SVN-Revision: 10329
Diffstat (limited to 'target/linux/adm5120/patches-2.6.24/310-adm5120_wdt.patch')
-rw-r--r--target/linux/adm5120/patches-2.6.24/310-adm5120_wdt.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/target/linux/adm5120/patches-2.6.24/310-adm5120_wdt.patch b/target/linux/adm5120/patches-2.6.24/310-adm5120_wdt.patch
new file mode 100644
index 0000000000..2f1ac5387a
--- /dev/null
+++ b/target/linux/adm5120/patches-2.6.24/310-adm5120_wdt.patch
@@ -0,0 +1,35 @@
+Index: linux-2.6.24/drivers/watchdog/Kconfig
+===================================================================
+--- linux-2.6.24.orig/drivers/watchdog/Kconfig
++++ linux-2.6.24/drivers/watchdog/Kconfig
+@@ -607,6 +607,18 @@ config SBC_EPX_C3_WATCHDOG
+
+ # MIPS Architecture
+
++config ADM5120_WDT
++ tristate "Infineon ADM5120 SoC hardware watchdog"
++ depends on WATCHDOG && MIPS_ADM5120
++ help
++ This is a driver for hardware watchdog integrated in Infineon
++ ADM5120 SoC. This watchdog simply watches your kernel to make sure
++ it doesn't freeze, and if it does, it reboots your computer after a
++ certain amount of time.
++
++ To compile this driver as a module, choose M here: the module will be
++ called adm5120_wdt.
++
+ config INDYDOG
+ tristate "Indy/I2 Hardware Watchdog"
+ depends on SGI_IP22
+Index: linux-2.6.24/drivers/watchdog/Makefile
+===================================================================
+--- linux-2.6.24.orig/drivers/watchdog/Makefile
++++ linux-2.6.24/drivers/watchdog/Makefile
+@@ -89,6 +89,7 @@ obj-$(CONFIG_SBC_EPX_C3_WATCHDOG) += sbc
+ # M68KNOMMU Architecture
+
+ # MIPS Architecture
++obj-$(CONFIG_ADM5120_WDT) += adm5120_wdt.o
+ obj-$(CONFIG_INDYDOG) += indydog.o
+ obj-$(CONFIG_WDT_MTX1) += mtx-1_wdt.o
+ obj-$(CONFIG_WDT_RM9K_GPI) += rm9k_wdt.o