diff options
author | Felix Fietkau <nbd@openwrt.org> | 2009-03-03 14:55:53 +0000 |
---|---|---|
committer | Felix Fietkau <nbd@openwrt.org> | 2009-03-03 14:55:53 +0000 |
commit | 431c9267b4016b7e712a0edf1e594bd71ac850b4 (patch) | |
tree | 2ac6aae6590e7bd3fec6de9d2446b64acf4aa4ed /rules.mk | |
parent | f3c14b3de8490a16cdb59f18239ce5afd3372708 (diff) | |
download | upstream-431c9267b4016b7e712a0edf1e594bd71ac850b4.tar.gz upstream-431c9267b4016b7e712a0edf1e594bd71ac850b4.tar.bz2 upstream-431c9267b4016b7e712a0edf1e594bd71ac850b4.zip |
replace a few unnecessary $(shell) calls
SVN-Revision: 14739
Diffstat (limited to 'rules.mk')
-rw-r--r-- | rules.mk | 8 |
1 files changed, 3 insertions, 5 deletions
@@ -19,9 +19,7 @@ TMP_DIR:=$(TOPDIR)/tmp export SHELL=/usr/bin/env bash -c '. $(TOPDIR)/include/shell.sh; eval "$$2"' -- -define qstrip -$(strip $(subst ",,$(1))) -endef +qstrip=$(strip $(subst ",,$(1))) #")) empty:= @@ -31,7 +29,7 @@ confvar=$(call merge,$(foreach v,$(1),$(if $($(v)),y,n))) strip_last=$(patsubst %.$(lastword $(subst .,$(space),$(1))),%,$(1)) _SINGLE=export MAKEFLAGS=$(space); -ARCH:=$(call qstrip,$(shell echo $(CONFIG_ARCH) | sed -e 's/i[3-9]86/i386/')) +ARCH:=$(subst i486,i386,$(subst i586,i386,$(subst i686,i386,$(call qstrip,$(CONFIG_ARCH))))) BOARD:=$(call qstrip,$(CONFIG_TARGET_BOARD)) TARGET_OPTIMIZATION:=$(call qstrip,$(CONFIG_TARGET_OPTIMIZATION)) TARGET_SUFFIX=$(call qstrip,$(CONFIG_TARGET_SUFFIX)) @@ -41,7 +39,7 @@ LIBC:=$(call qstrip,$(CONFIG_LIBC)) LIBCV:=$(call qstrip,$(CONFIG_LIBC_VERSION)) SUBDIR:=$(patsubst $(TOPDIR)/%,%,${CURDIR}) -OPTIMIZE_FOR_CPU=$(shell echo $(ARCH) | sed -e 's/i386/i486/') +OPTIMIZE_FOR_CPU=$(subst i386,i486,$(ARCH)) ifeq ($(ARCH),powerpc) FPIC:=-fPIC |