diff options
author | Michael Pratt <mcpratt@pm.me> | 2023-04-20 12:31:16 -0400 |
---|---|---|
committer | Christian Marangi <ansuelsmth@gmail.com> | 2023-05-04 06:07:23 +0200 |
commit | ffd7c05aa72ee56b836903159540f9470aeef121 (patch) | |
tree | 0d028215e58aa93d2d2a9ea4271dd1d373136daf /rules.mk | |
parent | 0c117e1f6ccbee684ea0589d9024ca9dec4679c9 (diff) | |
download | upstream-ffd7c05aa72ee56b836903159540f9470aeef121.tar.gz upstream-ffd7c05aa72ee56b836903159540f9470aeef121.tar.bz2 upstream-ffd7c05aa72ee56b836903159540f9470aeef121.zip |
prereq-build: add check for true and false
Some uses cases, like with autotools, need a path for 'true'
if we use them to force something to skip.
This will work by default on Linux hosts,
and require MacOS hosts to get coreutils,
which is currently installed in the CI
for 'macos-latest' host.
In the future, prereq stage can be reworked
to search for the actual binary
instead of relying on env.
Signed-off-by: Michael Pratt <mcpratt@pm.me>
Diffstat (limited to 'rules.mk')
-rw-r--r-- | rules.mk | 8 |
1 files changed, 8 insertions, 0 deletions
@@ -268,6 +268,14 @@ FIND:=find PATCH:=patch PYTHON:=python3 +ifeq ($(HOST_OS),Darwin) + TRUE:=/usr/bin/env gtrue + FALSE:=/usr/bin/env gfalse +else + TRUE:=/usr/bin/env true + FALSE:=/usr/bin/env false +endif + INSTALL_BIN:=install -m0755 INSTALL_SUID:=install -m4755 INSTALL_DIR:=install -d -m0755 |