diff options
author | Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk> | 2022-06-21 14:15:40 +0100 |
---|---|---|
committer | Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk> | 2022-06-21 16:41:17 +0100 |
commit | 24e27bec9a6df1511a504cf04cd9578a23e74657 (patch) | |
tree | fd08b5aaf1ea78d5817627819f60d56848254be3 /rules.mk | |
parent | 33e7f7c0285619c3be58ae7db5617bea9938a46a (diff) | |
download | upstream-24e27bec9a6df1511a504cf04cd9578a23e74657.tar.gz upstream-24e27bec9a6df1511a504cf04cd9578a23e74657.tar.bz2 upstream-24e27bec9a6df1511a504cf04cd9578a23e74657.zip |
kernel: filter -no-plt from KCFLAGS
Compiler option -no-plt will break kernel builds on some architectures
eg. (x86) Filter this option from the recently introduced handling of
KCFLAGS vs EXTRA_OPTIMISATION
Fixes: 1d42af720c6b ("kernel: use KCFLAGS for passing EXTRA_OPTIMIZATION flags")
Suggested-by: Felix Fietkau <nbd@nbd.name>
Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Diffstat (limited to 'rules.mk')
-rw-r--r-- | rules.mk | 1 |
1 files changed, 0 insertions, 1 deletions
@@ -62,7 +62,6 @@ ARCH_PACKAGES:=$(call qstrip,$(CONFIG_TARGET_ARCH_PACKAGES)) BOARD:=$(call qstrip,$(CONFIG_TARGET_BOARD)) SUBTARGET:=$(call qstrip,$(CONFIG_TARGET_SUBTARGET)) TARGET_OPTIMIZATION:=$(call qstrip,$(CONFIG_TARGET_OPTIMIZATION)) -export EXTRA_OPTIMIZATION:=$(filter-out -fno-plt,$(call qstrip,$(CONFIG_EXTRA_OPTIMIZATION))) TARGET_SUFFIX=$(call qstrip,$(CONFIG_TARGET_SUFFIX)) BUILD_SUFFIX:=$(call qstrip,$(CONFIG_BUILD_SUFFIX)) SUBDIR:=$(patsubst $(TOPDIR)/%,%,${CURDIR}) |