diff options
author | Felix Fietkau <nbd@openwrt.org> | 2008-06-09 15:38:45 +0000 |
---|---|---|
committer | Felix Fietkau <nbd@openwrt.org> | 2008-06-09 15:38:45 +0000 |
commit | 4c665e6ca4ce7044fbaf4e6a772b021c012f760c (patch) | |
tree | 2c5c0574cfda7d10c196399fd2791f5b57004f7b /rules.mk | |
parent | 21e09858f13eb471582ca09f1ce306a004203fb2 (diff) | |
download | upstream-4c665e6ca4ce7044fbaf4e6a772b021c012f760c.tar.gz upstream-4c665e6ca4ce7044fbaf4e6a772b021c012f760c.tar.bz2 upstream-4c665e6ca4ce7044fbaf4e6a772b021c012f760c.zip |
large improvement for parallel builds. works without V=99 now and without warnings. tested with -j on an 2x dual core opteron machine
SVN-Revision: 11414
Diffstat (limited to 'rules.mk')
-rw-r--r-- | rules.mk | 11 |
1 files changed, 6 insertions, 5 deletions
@@ -23,6 +23,12 @@ $(strip $(subst ",,$(1))) endef #")) +empty:= +space:= $(empty) $(empty) +merge=$(subst $(space),,$(1)) +confvar=$(call merge,$(foreach v,$(1),$(if $($(v)),y,n))) + +_SINGLE=MAKEFLAGS=$(space) ARCH:=$(call qstrip,$(shell echo $(CONFIG_ARCH) | sed -e 's/i[3-9]86/i386/')) BOARD:=$(call qstrip,$(CONFIG_TARGET_BOARD)) TARGET_OPTIMIZATION:=$(call qstrip,$(CONFIG_TARGET_OPTIMIZATION)) @@ -145,11 +151,6 @@ $(call shvar,$(1))=$$(call $(1)) export $(call shvar,$(1)) endef -empty:= -space:= $(empty) $(empty) -merge=$(subst $(space),,$(1)) -confvar=$(call merge,$(foreach v,$(1),$(if $($(v)),y,n))) - # file extension ext=$(word $(words $(subst ., ,$(1))),$(subst ., ,$(1))) |