diff options
author | Felix Fietkau <nbd@openwrt.org> | 2013-09-26 17:53:32 +0000 |
---|---|---|
committer | Felix Fietkau <nbd@openwrt.org> | 2013-09-26 17:53:32 +0000 |
commit | e0189ccef433f01304b97f89ffd52d1c3b48498b (patch) | |
tree | 0ca4ccd943142e324dc59f2732eb92ab9dce680c /rules.mk | |
parent | 0db91251574fd221641a5d89564d244e5406e44f (diff) | |
download | upstream-e0189ccef433f01304b97f89ffd52d1c3b48498b.tar.gz upstream-e0189ccef433f01304b97f89ffd52d1c3b48498b.tar.bz2 upstream-e0189ccef433f01304b97f89ffd52d1c3b48498b.zip |
build: include the cpu type as part of the toolchain/target directory name
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 38214
Diffstat (limited to 'rules.mk')
-rw-r--r-- | rules.mk | 15 |
1 files changed, 4 insertions, 11 deletions
@@ -54,22 +54,15 @@ endif HOST_FPIC:=-fPIC -ARCH_SUFFIX:= +ARCH_SUFFIX:=$(call qstrip,$(CONFIG_CPU_TYPE)) GCC_ARCH:= +ifneq ($(ARCH_SUFFIX),) + ARCH_SUFFIX:=_$(ARCH_SUFFIX) +endif ifneq ($(filter -march=armv%,$(TARGET_OPTIMIZATION)),) - ARCH_SUFFIX:=_$(patsubst -march=arm%,%,$(filter -march=armv%,$(TARGET_OPTIMIZATION))) GCC_ARCH:=$(patsubst -march=%,%,$(filter -march=armv%,$(TARGET_OPTIMIZATION))) endif -ifneq ($(filter -mips%r2,$(TARGET_OPTIMIZATION)),) - ARCH_SUFFIX:=_r2 -endif -ifneq ($(filter -mdsp,$(TARGET_OPTIMIZATION)),) - ARCH_SUFFIX:=$(ARCH_SUFFIX)_dsp -endif -ifneq ($(filter -mdspr2,$(TARGET_OPTIMIZATION)),) - ARCH_SUFFIX:=$(ARCH_SUFFIX)_dspr2 -endif ifdef CONFIG_HAS_SPE_FPU TARGET_SUFFIX:=$(TARGET_SUFFIX)spe endif |