diff options
author | Felix Fietkau <nbd@openwrt.org> | 2013-08-14 13:02:29 +0000 |
---|---|---|
committer | Felix Fietkau <nbd@openwrt.org> | 2013-08-14 13:02:29 +0000 |
commit | a1a5f59ea358fc35805f003466c98f08f5299e9d (patch) | |
tree | 57465ec975a600a13a602da95c0aa72cb440662b /rules.mk | |
parent | 8b8875b305e3e36153f83d08c68596fe0303efa4 (diff) | |
download | upstream-a1a5f59ea358fc35805f003466c98f08f5299e9d.tar.gz upstream-a1a5f59ea358fc35805f003466c98f08f5299e9d.tar.bz2 upstream-a1a5f59ea358fc35805f003466c98f08f5299e9d.zip |
build: decouple the mips16 support flag from the toolchain
Add the flags from package.mk instead, and leave libc and gcc
unaffected.
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 37770
Diffstat (limited to 'rules.mk')
-rw-r--r-- | rules.mk | 10 |
1 files changed, 2 insertions, 8 deletions
@@ -70,13 +70,6 @@ endif ifneq ($(filter -mdspr2,$(TARGET_OPTIMIZATION)),) ARCH_SUFFIX:=$(ARCH_SUFFIX)_dspr2 endif -ifdef CONFIG_USE_MIPS16 - TARGET_OPTIMIZATION+= -minterlink-mips16 -mips16 -endif -ifneq ($(findstring -mips16,$(TARGET_OPTIMIZATION)),) - TARGET_ASFLAGS_OVERRIDE:=-mno-mips16 - ARCH_SUFFIX:= $(ARCH_SUFFIX)_m16 -endif ifdef CONFIG_HAS_SPE_FPU TARGET_SUFFIX:=$(TARGET_SUFFIX)spe endif @@ -130,7 +123,8 @@ PKG_INFO_DIR := $(STAGING_DIR)/pkginfo TARGET_PATH:=$(STAGING_DIR_HOST)/bin:$(subst $(space),:,$(filter-out .,$(filter-out ./,$(subst :,$(space),$(PATH))))) TARGET_CFLAGS:=$(TARGET_OPTIMIZATION)$(if $(CONFIG_DEBUG), -g3) $(EXTRA_OPTIMIZATION) TARGET_CXXFLAGS = $(TARGET_CFLAGS) -TARGET_ASFLAGS = $(TARGET_CFLAGS) $(TARGET_ASFLAGS_OVERRIDE) +TARGET_ASFLAGS_DEFAULT = $(TARGET_CFLAGS) +TARGET_ASFLAGS = $(TARGET_ASFLAGS_DEFAULT) TARGET_CPPFLAGS:=-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include TARGET_LDFLAGS:=-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib ifneq ($(CONFIG_EXTERNAL_TOOLCHAIN),) |