diff options
author | Felix Fietkau <nbd@openwrt.org> | 2007-02-25 17:49:25 +0000 |
---|---|---|
committer | Felix Fietkau <nbd@openwrt.org> | 2007-02-25 17:49:25 +0000 |
commit | ced1277147f529e3bcc2eddbc3fe6e78eff562a8 (patch) | |
tree | b08502ee5072906a5911c4ebaf54d0805e071e82 /rules.mk | |
parent | 92feed28d882bf9dc75f59e2ed183e84362935d9 (diff) | |
download | upstream-ced1277147f529e3bcc2eddbc3fe6e78eff562a8.tar.gz upstream-ced1277147f529e3bcc2eddbc3fe6e78eff562a8.tar.bz2 upstream-ced1277147f529e3bcc2eddbc3fe6e78eff562a8.zip |
clean up stampfile mess for tools/ and toolchain/
SVN-Revision: 6357
Diffstat (limited to 'rules.mk')
-rw-r--r-- | rules.mk | 20 |
1 files changed, 20 insertions, 0 deletions
@@ -130,6 +130,26 @@ $(call shvar,$(1))=$$(call $(1)) export $(call shvar,$(1)) endef +# Default targets for subdirectory calls +# Parameters: +# 1: dependencies for the prepare step +define default_subtargets + %-download: FORCE + $$(MAKE) -C $$(patsubst %-download,%,$$@) download + + %-prepare: $(1) FORCE + $$(MAKE) -C $$(patsubst %-prepare,%,$$@) prepare + + %-compile: %-prepare + $$(MAKE) -C $$(patsubst %-compile,%,$$@) compile + + %-install: %-compile + $$(MAKE) -C $$(patsubst %-install,%,$$@) install + + %-clean: FORCE + @$$(MAKE) -C $$(patsubst %-clean,%,$$@) clean +endef + all: FORCE: ; |