aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2013-09-05 19:53:21 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2013-09-05 19:53:21 +0000
commitfd561a47c51aed0ff7ed6a7167ee598d2417d890 (patch)
tree5339d05a1d21eac78dac6756bc1d590e9f39a66c /package
parent11ae55cc957e0b51deacd9261a88bc5d7cc5ea9a (diff)
downloadupstream-fd561a47c51aed0ff7ed6a7167ee598d2417d890.tar.gz
upstream-fd561a47c51aed0ff7ed6a7167ee598d2417d890.tar.bz2
upstream-fd561a47c51aed0ff7ed6a7167ee598d2417d890.zip
kernel: kmod-firewire: fix dependencies
This fixes the following error: firewire_core: Unknown symbol crc_itu_t (err 0) Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> SVN-Revision: 37902
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/firewire.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/firewire.mk b/package/kernel/linux/modules/firewire.mk
index d3b4ef701c..0d5a7dfc7d 100644
--- a/package/kernel/linux/modules/firewire.mk
+++ b/package/kernel/linux/modules/firewire.mk
@@ -13,7 +13,7 @@ define KernelPackage/firewire
DEPENDS:=@PCI_SUPPORT +kmod-lib-crc-itu-t
KCONFIG:=CONFIG_FIREWIRE
FILES:=$(LINUX_DIR)/drivers/firewire/firewire-core.ko
- AUTOLOAD:=$(call AutoLoad,20,firewire-core)
+ AUTOLOAD:=$(call AutoLoad,25,firewire-core)
endef
define KernelPackage/firewire/description
ring.Backtick */ .highlight .sc { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Char */ .highlight .dl { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Delimiter */ .highlight .sd { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Doc */ .highlight .s2 { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Double */ .highlight .se { color: #0044dd; background-color: #fff0f0 } /* Literal.String.Escape */ .highlight .sh { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Heredoc */ .highlight .si { color: #3333bb; background-color: #fff0f0 } /* Literal.String.Interpol */ .highlight .sx { color: #22bb22; background-color: #f0fff0 } /* Literal.String.Other */ .highlight .sr { color: #008800; background-color: #fff0ff } /* Literal.String.Regex */ .highlight .s1 { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Single */ .highlight .ss { color: #aa6600; background-color: #fff0f0 } /* Literal.String.Symbol */ .highlight .bp { color: #003388 } /* Name.Builtin.Pseudo */ .highlight .fm { color: #0066bb; font-weight: bold } /* Name.Function.Magic */ .highlight .vc { color: #336699 } /* Name.Variable.Class */ .highlight .vg { color: #dd7700 } /* Name.Variable.Global */ .highlight .vi { color: #3333bb } /* Name.Variable.Instance */ .highlight .vm { color: #336699 } /* Name.Variable.Magic */ .highlight .il { color: #0000DD; font-weight: bold } /* Literal.Number.Integer.Long */
#!/bin/sh
# Create a new openwrt tree with symlinks pointing at the current tree
# Usage: ./scripts/symlink-tree.sh <destination>

FILES="
	BSDmakefile
	config
	Config.in
	LICENSE
	Makefile
	README
	dl
	feeds.conf.default
	include
	package
	rules.mk
	scripts
	target
	toolchain
	tools"

OPTIONAL_FILES="
	.git"

if [ -f feeds.conf ] ; then
	FILES="$FILES feeds.conf"
fi

if [ -z "$1" ]; then
	echo "Syntax: $0 <destination>" >&2
	exit 1
fi

if [ -e "$1" ]; then
	echo "Error: $1 already exists" >&2
	exit 1
fi

set -e # fail if any commands fails
mkdir -p dl "$1"
for file in $FILES; do
	[ -e "$PWD/$file" ] || {
		echo "ERROR: $file does not exist in the current tree" >&2
		exit 1
	}
	ln -s "$PWD/$file" "$1/"
done
for file in $OPTIONAL_FILES; do
	[ -e "$PWD/$file" ] && ln -s "$PWD/$file" "$1/"
done
exit 0