aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2011-07-05 12:40:59 +0000
committerFlorian Fainelli <florian@openwrt.org>2011-07-05 12:40:59 +0000
commitbbece7e4e8303a4fc493a3e944cb9fe53534831c (patch)
tree7965caae18d5ac2f937d7c6dfafce647b91d845d /package
parent42a78d909ed71b79fa75b3b2fcd2facaba334bf8 (diff)
downloadupstream-bbece7e4e8303a4fc493a3e944cb9fe53534831c.tar.gz
upstream-bbece7e4e8303a4fc493a3e944cb9fe53534831c.tar.bz2
upstream-bbece7e4e8303a4fc493a3e944cb9fe53534831c.zip
iptables: add iptables-mod-led (#9400)
SVN-Revision: 27460
Diffstat (limited to 'package')
-rw-r--r--package/iptables/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/package/iptables/Makefile b/package/iptables/Makefile
index 61739d3551..581c0fcdc4 100644
--- a/package/iptables/Makefile
+++ b/package/iptables/Makefile
@@ -217,6 +217,17 @@ Includes:
- libipt_recent
endef
+define Package/iptables-mod-led
+$(call Package/iptables/Module, +kmod-ipt-led)
+ TITLE:=LED trigger iptables extension
+endef
+
+define Package/iptables-mod-led/description
+iptables extension for triggering a LED.
+Includes:
+- libxt_LED
+endef
+
define Package/iptables-mod-tproxy
$(call Package/iptables/Module, +kmod-ipt-tproxy)
TITLE:=Transparent proxy iptables extensions
@@ -444,6 +455,7 @@ $(eval $(call BuildPlugin,iptables-mod-nat-extra,$(IPT_NAT_EXTRA-m)))
$(eval $(call BuildPlugin,iptables-mod-iprange,$(IPT_IPRANGE-m)))
$(eval $(call BuildPlugin,iptables-mod-ulog,$(IPT_ULOG-m)))
$(eval $(call BuildPlugin,iptables-mod-hashlimit,$(IPT_HASHLIMIT-m)))
+$(eval $(call BuildPlugin,iptables-mod-led,$(IPT_LED-m)))
$(eval $(call BuildPlugin,iptables-mod-tproxy,$(IPT_TPROXY-m)))
$(eval $(call BuildPlugin,iptables-mod-tee,$(IPT_TEE-m)))
$(eval $(call BuildPlugin,iptables-mod-u32,$(IPT_U32-m)))
190 191 192 193 194 195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 217 218 219 220 221 222 223 224 225 226 227 228 229 230 231 232 233 234 235 236 237 238 239 240 241 242 243 244 245 246 247 248 249 250 251 252 253 254 255 256 257 258 259 260 261 262 263 264 265 266 267 268 269 270 271 272 273 274 275 276 277 278 279 280 281 282 283 284 285 286 287 288 289 290 291 292 293 294 295 296 297 298 299 300 301 302 303 304 305 306 307 308 309 310 311 312 313 314 315 316 317 318 319 320 321 322 323 324 325 326 327 328 329 330 331 332 333 334 335 336 337 338 339 340