aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils/uencrypt/Makefile
diff options
context:
space:
mode:
authorEneas U de Queiroz <cotequeiroz@gmail.com>2023-02-18 23:19:31 -0300
committerEneas U de Queiroz <cotequeiroz@gmail.com>2023-03-17 17:22:54 -0300
commit1781e7408a62de72193ddff5dbf5d9ff772a5847 (patch)
tree1f17ce06d8e6400608324bf8d41f746573fbf84a /package/utils/uencrypt/Makefile
parent4662adef2ad02dc5903516f69da017dcecf392c9 (diff)
downloadupstream-1781e7408a62de72193ddff5dbf5d9ff772a5847.tar.gz
upstream-1781e7408a62de72193ddff5dbf5d9ff772a5847.tar.bz2
upstream-1781e7408a62de72193ddff5dbf5d9ff772a5847.zip
uencrypt: split common and library-specific code
This splits the code in 4 files: - uencrypt.h - uencrypt.c - main program - uencrypt-openssl.c - OpenSSL/wolfSSL implementation - uencrypt-mbedtls - mbedTLS implementation Other changes, accounting for ~400 bytes increase in ipk size: - more error condition checking and reporting, - hide key and iv command line arguments Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
Diffstat (limited to 'package/utils/uencrypt/Makefile')
-rw-r--r--package/utils/uencrypt/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/utils/uencrypt/Makefile b/package/utils/uencrypt/Makefile
index 21d2d96f4d..70ca655b6e 100644
--- a/package/utils/uencrypt/Makefile
+++ b/package/utils/uencrypt/Makefile
@@ -4,7 +4,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=uencrypt
-PKG_RELEASE:=4
+PKG_RELEASE:=5
PKG_LICENSE:=GPL-2.0-or-later
PKG_MAINTAINER:=Eneas U de Queiroz <cotequeiroz@gmail.com>
@@ -19,6 +19,8 @@ else ifeq ($(BUILD_VARIANT),wolfssl)
CMAKE_OPTIONS+=-DUSE_WOLFSSL=1
endif
+TARGET_CFLAGS+=-Wall
+
define Package/uencrypt/default
SECTION:=utils
CATEGORY:=Base system