aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils/px5g-standalone/src/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-02-21 14:24:32 +0100
committerFelix Fietkau <nbd@nbd.name>2017-02-21 16:05:42 +0100
commit709d10e220071da00ecbf6d6f5281719bee58a46 (patch)
tree340487140206cb884ac767eab3fbcf7b9ab4df88 /package/utils/px5g-standalone/src/Makefile
parent7df0069bb5c51907ba54a5342c755ad8e19e57a9 (diff)
downloadupstream-709d10e220071da00ecbf6d6f5281719bee58a46.tar.gz
upstream-709d10e220071da00ecbf6d6f5281719bee58a46.tar.bz2
upstream-709d10e220071da00ecbf6d6f5281719bee58a46.zip
px5g: replace px5g-standalone with a statically linked variant of px5g-mbedtls
px5g-standalone only supports SHA1 for certificates, which is strongly deprecated. The new px5g-standalone is about 27k bigger (compressed), and has identical behavior to px5g-mbedtls (it uses SHA256). Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/utils/px5g-standalone/src/Makefile')
-rw-r--r--package/utils/px5g-standalone/src/Makefile14
1 files changed, 0 insertions, 14 deletions
diff --git a/package/utils/px5g-standalone/src/Makefile b/package/utils/px5g-standalone/src/Makefile
deleted file mode 100644
index 2bd95739cb..0000000000
--- a/package/utils/px5g-standalone/src/Makefile
+++ /dev/null
@@ -1,14 +0,0 @@
-CFLAGS?=-O2
-CFLAGS+=
-SFLAGS:=--std=gnu99
-WFLAGS:=-Wall -Werror -pedantic
-LDFLAGS?=
-BINARY:=px5g
-
-all: $(BINARY)
-
-$(BINARY): *.c library/*.c
- $(CC) -I. $(CFLAGS) $(SFLAGS) $(WFLAGS) $(LDFLAGS) -o $@ $+
-
-clean:
- rm -f $(BINARY)