aboutsummaryrefslogtreecommitdiffstats
path: root/package/nw802-2.4/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2008-08-09 20:36:05 +0000
committerFelix Fietkau <nbd@openwrt.org>2008-08-09 20:36:05 +0000
commit91a01e41067edb1d08727e7170b2fe76c4859f9c (patch)
tree6e5df70693528290fa1e26ae1a88c32538dec39c /package/nw802-2.4/Makefile
parentd7c8f38007061b0c984785ee3a45ab0ca0da9915 (diff)
downloadupstream-91a01e41067edb1d08727e7170b2fe76c4859f9c.tar.gz
upstream-91a01e41067edb1d08727e7170b2fe76c4859f9c.tar.bz2
upstream-91a01e41067edb1d08727e7170b2fe76c4859f9c.zip
move some webcam/sound related stuff from trunk to packages
SVN-Revision: 12260
Diffstat (limited to 'package/nw802-2.4/Makefile')
-rw-r--r--package/nw802-2.4/Makefile45
1 files changed, 0 insertions, 45 deletions
diff --git a/package/nw802-2.4/Makefile b/package/nw802-2.4/Makefile
deleted file mode 100644
index ff39ad7720..0000000000
--- a/package/nw802-2.4/Makefile
+++ /dev/null
@@ -1,45 +0,0 @@
-#
-# Copyright (C) 2006-2008 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-# $Id$
-
-include $(TOPDIR)/rules.mk
-include $(INCLUDE_DIR)/kernel.mk
-
-PKG_NAME:=nw802-2.4
-PKG_VERSION:=0.0.99
-PKG_RELEASE:=1
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=@SF/nw802
-PKG_MD5SUM:=bf3512efaa48cfa972b16318011c1963
-
-include $(INCLUDE_DIR)/package.mk
-
-define KernelPackage/video-nw8xx
- SUBMENU:=Video Support
- TITLE:=NW8xx based USB webcam support
- URL:=http://nw802.sourceforge.net/
- DEPENDS:=@LINUX_2_6 @USB_SUPPORT +kmod-usb-video kmod-video-core
- FILES:=$(PKG_BUILD_DIR)/nw8xx.$(LINUX_KMOD_SUFFIX)
- AUTOLOAD:=$(call AutoLoad,70,nw8xx)
-endef
-
-define KernelPackage/video-nw8xx/description
- Kernel support for NW8xx based USB cameras.
-endef
-
-define Build/Compile
- ln -sf $(LINUX_DIR)/drivers/media/video/usbvideo/usbvideo.h \
- $(PKG_BUILD_DIR)/
- $(MAKE) -C $(LINUX_DIR) \
- ARCH="$(LINUX_KARCH)" \
- CROSS_COMPILE="$(TARGET_CROSS)" \
- SUBDIRS="$(PKG_BUILD_DIR)" \
- modules
-endef
-
-$(eval $(call KernelPackage,video-nw8xx))