aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/nftables/Makefile
diff options
context:
space:
mode:
authorRosy Song <rosysong@rosinson.com>2018-05-15 11:42:29 +0800
committerJo-Philipp Wich <jo@mein.io>2018-12-18 07:54:54 +0100
commit25f58ed81a34a5528e9d51c2fbd34c568919e516 (patch)
tree8fea54f641898e6ac8d234cbe29e9cb62e747736 /package/network/utils/nftables/Makefile
parent1e432993c513a613c1823ae7ccd88192df84f07a (diff)
downloadupstream-25f58ed81a34a5528e9d51c2fbd34c568919e516.tar.gz
upstream-25f58ed81a34a5528e9d51c2fbd34c568919e516.tar.bz2
upstream-25f58ed81a34a5528e9d51c2fbd34c568919e516.zip
nftables: bump to 0.8.5 version
Signed-off-by: Rosy Song <rosysong@rosinson.com> (backported from 39e87e0ffc4eabf27d25459a369be425e9ef0474)
Diffstat (limited to 'package/network/utils/nftables/Makefile')
-rw-r--r--package/network/utils/nftables/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/package/network/utils/nftables/Makefile b/package/network/utils/nftables/Makefile
index 182fcace3b..c7f8a946be 100644
--- a/package/network/utils/nftables/Makefile
+++ b/package/network/utils/nftables/Makefile
@@ -7,22 +7,25 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=nftables
-PKG_VERSION:=0.8.2
+PKG_VERSION:=0.8.5
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://netfilter.org/projects/$(PKG_NAME)/files
-PKG_HASH:=675f0aaf88f11e7eacef63dc89cb65d207d9e09c3ea6d518f0ebbb013f0767ec
+PKG_HASH:=8e9baf80a1c7f0e19e5b50e469bda4487793d839da45c75e8a20fadcbaeae323
PKG_MAINTAINER:=Steven Barth <steven@midlink.org>
PKG_LICENSE:=GPL-2.0
PKG_FIXUP:=autoreconf
+PKG_INSTALL:=1
include $(INCLUDE_DIR)/package.mk
DISABLE_NLS:=
CONFIGURE_ARGS += \
+ --disable-debug \
+ --disable-man-doc \
--with-mini-gmp \
--without-cli \
@@ -37,7 +40,9 @@ endef
define Package/nftables/install
$(INSTALL_DIR) $(1)/usr/sbin
- $(CP) $(PKG_BUILD_DIR)/src/nft $(1)/usr/sbin/
+ $(CP) $(PKG_INSTALL_DIR)/usr/sbin/nft $(1)/usr/sbin/
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/*.so* $(1)/usr/lib/
endef
$(eval $(call BuildPackage,nftables))