aboutsummaryrefslogtreecommitdiffstats
path: root/package/mac80211/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-03-17 20:21:28 +0000
committerFelix Fietkau <nbd@openwrt.org>2011-03-17 20:21:28 +0000
commitdaf32f2647f810c9f31265e432ae2d78b49adfe3 (patch)
tree8a6e590bd10b3f809bd3c0632fc0f892ebbb611e /package/mac80211/Makefile
parent438ced7a7afde4de0b7cba49ae581dfe8155103f (diff)
downloadupstream-daf32f2647f810c9f31265e432ae2d78b49adfe3.tar.gz
upstream-daf32f2647f810c9f31265e432ae2d78b49adfe3.tar.bz2
upstream-daf32f2647f810c9f31265e432ae2d78b49adfe3.zip
hostapd: add a separate config symbol for 802.11n driver support
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@26212 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/mac80211/Makefile')
-rw-r--r--package/mac80211/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/mac80211/Makefile b/package/mac80211/Makefile
index 7eb01f0edf..eaea213961 100644
--- a/package/mac80211/Makefile
+++ b/package/mac80211/Makefile
@@ -274,7 +274,7 @@ endef
define KernelPackage/rt2800-lib
$(call KernelPackage/rt2x00/Default)
- DEPENDS+= @(PCI_SUPPORT||USB_SUPPORT||TARGET_ramips) +kmod-rt2x00-lib +USB_SUPPORT:kmod-rt2x00-usb +TARGET_ramips:kmod-rt2x00-soc
+ DEPENDS+= @(PCI_SUPPORT||USB_SUPPORT||TARGET_ramips) +kmod-rt2x00-lib +USB_SUPPORT:kmod-rt2x00-usb +TARGET_ramips:kmod-rt2x00-soc +@DRIVER_11N_SUPPORT
TITLE+= (rt2800 LIB)
FILES:=$(PKG_BUILD_DIR)/drivers/net/wireless/rt2x00/rt2800lib.ko
AUTOLOAD:=$(call AutoLoad,27,rt2800lib)
@@ -431,7 +431,7 @@ define KernelPackage/ath9k-common
$(call KernelPackage/mac80211/Default)
TITLE:=Atheros 802.11n wireless devices (common code for ath9k and ath9k_htc)
URL:=http://linuxwireless.org/en/users/Drivers/ath9k
- DEPENDS+= @PCI_SUPPORT +kmod-ath
+ DEPENDS+= @PCI_SUPPORT +kmod-ath +@DRIVER_11N_SUPPORT
FILES:= \
$(PKG_BUILD_DIR)/drivers/net/wireless/ath/ath9k/ath9k_common.ko \
$(PKG_BUILD_DIR)/drivers/net/wireless/ath/ath9k/ath9k_hw.ko
@@ -496,7 +496,7 @@ endef
define KernelPackage/carl9170
$(call KernelPackage/mac80211/Default)
TITLE:=Driver for Atheros AR9170 USB sticks
- DEPENDS:=@USB_SUPPORT +kmod-mac80211 +kmod-ath +kmod-usb-core
+ DEPENDS:=@USB_SUPPORT +kmod-mac80211 +kmod-ath +kmod-usb-core +@DRIVER_11N_SUPPORT
FILES:=$(PKG_BUILD_DIR)/drivers/net/wireless/ath/carl9170/carl9170.ko
AUTOLOAD:=$(call AutoLoad,60,carl9170)
endef