aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/wolfssl
diff options
context:
space:
mode:
authorChristian 'Ansuel' Marangi <ansuelsmth@gmail.com>2022-06-09 00:40:47 +0200
committerChristian 'Ansuel' Marangi <ansuelsmth@gmail.com>2022-06-09 00:47:13 +0200
commite0cc5b9b3ae65113f0e0dd9249dae4776b65c503 (patch)
tree091f4dcee4cac95af8dffa66548f54b4a36face3 /package/libs/wolfssl
parentb72c7db2293cf728851696e6370806cc3e0fa305 (diff)
downloadupstream-e0cc5b9b3ae65113f0e0dd9249dae4776b65c503.tar.gz
upstream-e0cc5b9b3ae65113f0e0dd9249dae4776b65c503.tar.bz2
upstream-e0cc5b9b3ae65113f0e0dd9249dae4776b65c503.zip
wolfssl: set nonshared flag global
libwolfssl-benchmark should NOT be compiled as nonshared but currently there is a bug where, on buildbot stage2, the package is recompiled to build libwolfssl-benchmark and the dependency change to the new libwolfssl version. Each dependant package will now depend on the new wolfssl package instead of the one previously on stage1 that has a different package HASH. Set the nonshared PKGFLAGS global while this gets investigated and eventually fixed. Fixes: 0a2edc2714dc ("wolfssl: enable CPU crypto instructions") Signed-off-by: Christian 'Ansuel' Marangi <ansuelsmth@gmail.com>
Diffstat (limited to 'package/libs/wolfssl')
-rw-r--r--package/libs/wolfssl/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/package/libs/wolfssl/Makefile b/package/libs/wolfssl/Makefile
index 3edd526364..7176995ec2 100644
--- a/package/libs/wolfssl/Makefile
+++ b/package/libs/wolfssl/Makefile
@@ -48,6 +48,15 @@ PKG_CONFIG_DEPENDS+=\
CONFIG_WOLFSSL_HAS_DEVCRYPTO_CBC \
CONFIG_WOLFSSL_HAS_DEVCRYPTO_FULL
+#
+# libwolfssl-benchmark should NOT be compiled as nonshared but
+# currently there is a bug where on buildbot stage2 the package
+# is recompiled to build libwolfssl-benchmark and the dependency
+# change to the new libwolfssl version. While this gets
+# investigated, set the nonshared flag global
+#
+PKGFLAGS:=nonshared
+
include $(INCLUDE_DIR)/package.mk
define Package/libwolfssl/Default
@@ -60,7 +69,6 @@ endef
define Package/libwolfssl
$(call Package/libwolfssl/Default)
TITLE:=wolfSSL library
- PKGFLAGS:=nonshared
MENU:=1
PROVIDES:=libcyassl
DEPENDS:=+WOLFSSL_HAS_DEVCRYPTO:kmod-cryptodev +WOLFSSL_HAS_AFALG:kmod-crypto-user