aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorMathew McBride <matt@traverse.com.au>2023-08-21 06:10:35 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2023-09-16 21:00:38 +0200
commit5edeb1ee0c9484da0a0c07080f4bda4c33ab72bf (patch)
tree8ed563a4e59268967002497f281ff563bf1555a9 /package/kernel
parent68972704914915c47e9032588322322c6cc3e0aa (diff)
downloadupstream-5edeb1ee0c9484da0a0c07080f4bda4c33ab72bf.tar.gz
upstream-5edeb1ee0c9484da0a0c07080f4bda4c33ab72bf.tar.bz2
upstream-5edeb1ee0c9484da0a0c07080f4bda4c33ab72bf.zip
kernel: add vhost-net module
vhost-net is used to accelerate traffic to virtualisation guests that use the virtio-net network card in QEMU. Generally it is invoked by specifying "vhost=on" to a QEMU -netdev device: qemu-system-aarch64 -nographic -M virt -cpu host \ --enable-kvm -bios u-boot.bin -smp 1 -m 2048 \ -drive file=openwrt-armsr-armv8.img,format=raw,index=0,media=disk \ -device "virtio-net,netdev=landev,disable-legacy=off,disable-modern=off" \ -netdev "tap,id=landev,helper=/usr/lib/qemu-bridge-helper --br=br-lan,vhost=on" Signed-off-by: Mathew McBride <matt@traverse.com.au> (cherry picked from commit d188db8aed74547f98b905254d4f57baf225f1d6)
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/linux/modules/virt.mk24
1 files changed, 24 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/virt.mk b/package/kernel/linux/modules/virt.mk
index 90226b4806..1d9caa9bc8 100644
--- a/package/kernel/linux/modules/virt.mk
+++ b/package/kernel/linux/modules/virt.mk
@@ -117,3 +117,27 @@ define KernelPackage/vfio-pci/description
endef
$(eval $(call KernelPackage,vfio-pci))
+
+
+define KernelPackage/vhost
+ SUBMENU:=Virtualization
+ TITLE:=Host kernel accelerator for virtio (base)
+ KCONFIG:=CONFIG_VHOST
+ FILES:=$(LINUX_DIR)/drivers/vhost/vhost.ko \
+ $(LINUX_DIR)/drivers/vhost/vhost_iotlb.ko
+ AUTOLOAD:=$(call AutoProbe,vhost vhost_iotlb)
+endef
+
+$(eval $(call KernelPackage,vhost))
+
+
+define KernelPackage/vhost-net
+ SUBMENU:=Virtualization
+ TITLE:=Host kernel accelerator for virtio-net
+ DEPENDS:=+kmod-tun +kmod-vhost
+ KCONFIG:=CONFIG_VHOST_NET
+ FILES:=$(LINUX_DIR)/drivers/vhost/vhost_net.ko
+ AUTOLOAD:=$(call AutoProbe,vhost_net)
+endef
+
+$(eval $(call KernelPackage,vhost-net))