aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/mt76/Makefile
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2023-05-17 20:37:21 +0200
committerDavid Bauer <mail@david-bauer.net>2023-05-18 01:44:08 +0200
commitf7665a0f1a2da63e2046119c0c3de578f16651ce (patch)
tree4f3282659cd9d57922bb7d619249b30dfe1cfd07 /package/kernel/mt76/Makefile
parent9fa4aa63c5cd3bb0e48a369145e508c88ec194d2 (diff)
downloadupstream-f7665a0f1a2da63e2046119c0c3de578f16651ce.tar.gz
upstream-f7665a0f1a2da63e2046119c0c3de578f16651ce.tar.bz2
upstream-f7665a0f1a2da63e2046119c0c3de578f16651ce.zip
mt76: update to latest HEAD
969b7b5e wifi: mt76: mt7915: add support for MT7981 cddbd796 linux-firmware: add firmware for MT7981 c69b0239 linux-firmware: update firmware for MT7921 WiFi device c85a0f2f mt7921: remove duplicated line 0cbe1376 wifi: mt76: mt7915: drop redundant prefix of mt7915_txpower_puts() b490c6c7 wifi: mt76: fix 6GHz high channel not be scanned db5a8f70 wifi: mt76: move shared mac definitions in mt76_connac2_mac.h 3963ab2f wifi: mt76: mt7921: get rid of eeprom.h c09f943d wifi: mt76: add mt76_connac_gen_ppe_thresh utility routine 28ea992c wifi: mt76: get rid of unused sta_ps callbacks 2936b036 wifi: mt76: add mt76_connac_irq_enable utility routine 482d2a76 wifi: mt76: move irq_tasklet in mt76_dev struct 88d1b002 wifi: mt76: mt7996: enable mesh HW amsdu/de-amsdu support 577fbd47 linux-firmware: update firmware for MT7916 32be54b5 linux-firmware: update firmware for MT7921 WiFi device 4e2fad04 linux-firmware: update firmware for MT7922 WiFi device f8793b1a linux-firmware: update firmware for MT7921 WiFi device 91e6ad2a linux-firmware: update firmware for MT7921 WiFi device b7a538a3 linux-firmware: update firmware for MT7922 WiFi device e3b5a8cc wifi: mt76: mt7996: enable configured beacon tx rate a18bf481 wifi: mt76: mt7996: enable BSS_CHANGED_MCAST_RATE support f863beed wifi: mt76: mt7996: enable BSS_CHANGED_BASIC_RATES support aedc10d5 wifi: mt76: connac: add nss calculation into mt76_connac2_mac_tx_rate_val() 84a227e5 wifi: mt76: connac: fix txd multicast rate setting a0657180 wifi: mt76: mt7921e: stop chip reset worker in unregister hook fd895347 wifi: mt76: mt7921e: improve reliability of dma reset c9fa8d64 wifi: mt76: mt7921: fix missing unwind goto in `mt7921u_probe` c1baa812 mt76: mt7921: fix kernel panic by accessing unallocated eeprom.data ca180889 wifi: mt76: move mcu_uni_event and mcu_reg_event in common code 98fbca7a wifi: mt76: mt7996: enable coredump support be1ff24e wifi: mt76: mt7996: add full system reset knobs into debugfs b7a6c0ef wifi: mt76: mt7996: enable full system reset support 46f28e75 wifi: mt76: mt7921: enable p2p support 6a7e41c3 wifi: mt76: mt7921e: Set memory space enable in PCI_COMMAND if unset 084e6de7 wifi: mt76: mt7921: use driver flags rather than mac80211 flags to mcu c66e7a1a wifi: mt76: mt7921: introduce mt7921_get_mac80211_ops utility routine 821caac5 wifi: mt76: mt7996: fix eeprom tx path bitfields 9ae2569b wifi: mt76: mt7996: remove mt7996_mcu_set_pm() 3244d176 wifi: mt76: mt7996: init mpdu density cap 210a558a wifi: mt76: mt7996: fix pointer calculation in ie countdown event 207c92bb wifi: mt76: mt7996: remove unused eeprom band selection 16a24667 wifi: mt76: mt7996: let non-bufferable MMPDUs use correct hw queue d39bb7c8 wifi: mt76: mt7996: remove mt7996_mcu_beacon_check_caps() 4046b591 wifi: mt76: mt7915: remove mt7915_mcu_beacon_check_caps() d63cb85c wifi: mt76: add missing locking to protect against concurrent rx/status calls 22f1b777 mt76: adjust for ieee80211_is_bufferable_mmpdu API change 8ecf551c wifi: mt76: set NL80211_EXT_FEATURE_CAN_REPLACE_PTK0 on supported drivers efa44cb5 wifi: mt76: ignore key disable commands 56f0cd4d wifi: mt76: mt7915 add tc offloading support 021ded36 tools: Fix compile error with glibc Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'package/kernel/mt76/Makefile')
-rw-r--r--package/kernel/mt76/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/package/kernel/mt76/Makefile b/package/kernel/mt76/Makefile
index 34930d7693..1a7c2ec8c7 100644
--- a/package/kernel/mt76/Makefile
+++ b/package/kernel/mt76/Makefile
@@ -1,16 +1,16 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=mt76
-PKG_RELEASE=5
+PKG_RELEASE=1
PKG_LICENSE:=GPLv2
PKG_LICENSE_FILES:=
PKG_SOURCE_URL:=https://github.com/openwrt/mt76
PKG_SOURCE_PROTO:=git
-PKG_SOURCE_DATE:=2023-03-01
-PKG_SOURCE_VERSION:=c32d6d849c43792abd8007e13e468b12d6d6e0b7
-PKG_MIRROR_HASH:=b7004bc920ba44cef2f7868d94beb2d288ff9d399af624ce5dad972f953723c8
+PKG_SOURCE_DATE:=2023-05-13
+PKG_SOURCE_VERSION:=969b7b5ebd129068ca56e4b0d831593a2f92382f
+PKG_MIRROR_HASH:=d28869591d1cb9a967b72f5cd8215c7b2c3388b7b31147b7b18c797018ab8ffb
PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
PKG_USE_NINJA:=0
@@ -374,8 +374,8 @@ endif
ifdef CONFIG_PACKAGE_kmod-mt7915e
PKG_MAKE_FLAGS += CONFIG_MT7915E=m
ifdef CONFIG_TARGET_mediatek_filogic
- PKG_MAKE_FLAGS += CONFIG_MT7986_WMAC=y
- NOSTDINC_FLAGS += -DCONFIG_MT7986_WMAC
+ PKG_MAKE_FLAGS += CONFIG_MT798X_WMAC=y
+ NOSTDINC_FLAGS += -DCONFIG_MT798X_WMAC
endif
endif
ifdef CONFIG_PACKAGE_kmod-mt7921-common