aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/video.mk
diff options
context:
space:
mode:
authorNick Hainke <vincent@systemli.org>2023-05-04 22:47:27 +0200
committerChristian Marangi <ansuelsmth@gmail.com>2023-05-12 13:02:44 +0200
commit047361dee44cab2b2355f7b7859fd688f6483cbc (patch)
treec025ae837defcf9cd9afd3d11a1b2930ac5fe9f6 /package/kernel/linux/modules/video.mk
parentd798617d4aded6b922764bd5fea8651e12206afe (diff)
downloadupstream-047361dee44cab2b2355f7b7859fd688f6483cbc.tar.gz
upstream-047361dee44cab2b2355f7b7859fd688f6483cbc.tar.bz2
upstream-047361dee44cab2b2355f7b7859fd688f6483cbc.zip
treewide: cleanup kernel symbol references
We only use 5.15 kernel. So remove all those unnecessary symbols referencing 5.10 or 5.15 kernel. Can be found with: git grep -E 'LINUX_5_1(0|5)' Note that we remove the dependency from "sound-soc-chipdip-dac" instead of removing the complete kernel package. The 5.15 version bump forgot to delete the "@LINUX_5_10" dependency. The kernel package is still needed in 5.15 kernel. Signed-off-by: Nick Hainke <vincent@systemli.org>
Diffstat (limited to 'package/kernel/linux/modules/video.mk')
-rw-r--r--package/kernel/linux/modules/video.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/video.mk b/package/kernel/linux/modules/video.mk
index a89ceef54b..f1e61f33a5 100644
--- a/package/kernel/linux/modules/video.mk
+++ b/package/kernel/linux/modules/video.mk
@@ -226,7 +226,7 @@ define KernelPackage/drm
TITLE:=Direct Rendering Manager (DRM) support
HIDDEN:=1
DEPENDS:=+kmod-dma-buf +kmod-i2c-core +PACKAGE_kmod-backlight:kmod-backlight \
- +(LINUX_5_15):kmod-fb
+ +kmod-fb
KCONFIG:=CONFIG_DRM
FILES:= \
$(LINUX_DIR)/drivers/gpu/drm/drm.ko \