aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/crypto.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-01-31 13:55:51 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-01-31 13:55:51 +0000
commita3626aca95c5ec865a53b8bce2f739c77c3247da (patch)
tree8772bdd7f708edc9064faf85d4b2a05590aebce1 /package/kernel/linux/modules/crypto.mk
parent6e4e42727b34f890c9f37198b3ca1f32d6881466 (diff)
downloadupstream-a3626aca95c5ec865a53b8bce2f739c77c3247da.tar.gz
upstream-a3626aca95c5ec865a53b8bce2f739c77c3247da.tar.bz2
upstream-a3626aca95c5ec865a53b8bce2f739c77c3247da.zip
linux: convert CompareKernelPatchVer to version tagged symbols
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44229 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/crypto.mk')
-rw-r--r--package/kernel/linux/modules/crypto.mk11
1 files changed, 4 insertions, 7 deletions
diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index 2f1d33f4a4..4df2d7393a 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -329,13 +329,10 @@ define KernelPackage/crypto-crc32c
TITLE:=CRC32c CRC module
DEPENDS:=+kmod-crypto-hash
KCONFIG:=CONFIG_CRYPTO_CRC32C
-ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.15.0)),1)
- FILES:=$(LINUX_DIR)/crypto/crc32c_generic.ko
- AUTOLOAD:=$(call AutoLoad,04,crc32c_generic,1)
-else
- FILES:=$(LINUX_DIR)/crypto/crc32c.ko
- AUTOLOAD:=$(call AutoLoad,04,crc32c,1)
-endif
+ FILES:= \
+ $(LINUX_DIR)/crypto/crc32c.ko@lt3.15 \
+ $(LINUX_DIR)/crypto/crc32c_generic.ko@ge3.15
+ AUTOLOAD:=$(call AutoLoad,04,crc32c@lt3.15 crc32c_generic@ge3.15,1)
$(call AddDepends/crypto)
endef