aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/block.mk
diff options
context:
space:
mode:
authorAnsuel Smith <ansuelsmth@gmail.com>2021-11-04 21:59:09 +0100
committerDaniel Golle <daniel@makrotopia.org>2022-03-27 02:17:24 +0100
commitbd0db6017b1921c935785cdccdf0243fddf0b949 (patch)
tree692a9e678f7b97b0ee6cf8ccc5021fbcaba15b24 /package/kernel/linux/modules/block.mk
parentb268ec5ff8baed74037d04a74f61c0417d931ad9 (diff)
downloadupstream-bd0db6017b1921c935785cdccdf0243fddf0b949.tar.gz
upstream-bd0db6017b1921c935785cdccdf0243fddf0b949.tar.bz2
upstream-bd0db6017b1921c935785cdccdf0243fddf0b949.zip
kernel: 5.15: add new module
Add new module require in 5.15 - Changes in block module - Changes in netfilter module (log module unified) - Changes in fs module (mainly new depends for cifs and new ntfs3 module) - Changes in lib add shared lib now used by more than 1 kmod - Changes in crypto, dropped one crypto algo added arm crypto accellerator - Changes in other, add zram default compressor choice and missing lib by tpm module Signed-off-by: Ansuel Smith <ansuelsmth@gmail.com>
Diffstat (limited to 'package/kernel/linux/modules/block.mk')
-rw-r--r--package/kernel/linux/modules/block.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/block.mk b/package/kernel/linux/modules/block.mk
index e5822d95d7..dfb529db3b 100644
--- a/package/kernel/linux/modules/block.mk
+++ b/package/kernel/linux/modules/block.mk
@@ -513,11 +513,13 @@ define KernelPackage/scsi-core
TITLE:=SCSI device support
KCONFIG:= \
CONFIG_SCSI \
+ CONFIG_SCSI_COMMON@ge5.15 \
CONFIG_BLK_DEV_SD
FILES:= \
$(LINUX_DIR)/drivers/scsi/scsi_mod.ko \
+ $(LINUX_DIR)/drivers/scsi/scsi_common.ko@ge5.15 \
$(LINUX_DIR)/drivers/scsi/sd_mod.ko
- AUTOLOAD:=$(call AutoLoad,40,scsi_mod sd_mod,1)
+ AUTOLOAD:=$(call AutoLoad,40,scsi_mod scsi_common@ge5.15 sd_mod,1)
endef
$(eval $(call KernelPackage,scsi-core))