aboutsummaryrefslogtreecommitdiffstats
path: root/package/firmware/fritz-tools/Makefile
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2017-03-25 18:09:37 +0100
committerMathias Kresin <dev@kresin.me>2017-04-08 14:30:00 +0200
commit8b3fa168b49a4aad5797ef5083c17c348d99731b (patch)
treed7eac940d191855a585876a1a8018549981ca04d /package/firmware/fritz-tools/Makefile
parent136718a3d91bb392de8bc04d9fd59d86b4f460c0 (diff)
downloadupstream-8b3fa168b49a4aad5797ef5083c17c348d99731b.tar.gz
upstream-8b3fa168b49a4aad5797ef5083c17c348d99731b.tar.bz2
upstream-8b3fa168b49a4aad5797ef5083c17c348d99731b.zip
firmware: rework fritz-tools package
Split the fritz-tools into subpackages. fritz_tffs_read is usefull for all Fritz boards where fritz-cal_extract is only required for the Fritz 4040 at the moment. Rename the tffs related binary to the more catchy name fritz_tffs and move the whole package to utilities since the package doesn't really provide a firmware file. Make the fritz-tools available for all targets and build them shared. The tffs is used by avm on lantiq and ar71xx as well. Tested-by: Christian Lamparter <chunkeey@googlemail.com> Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'package/firmware/fritz-tools/Makefile')
-rw-r--r--package/firmware/fritz-tools/Makefile30
1 files changed, 0 insertions, 30 deletions
diff --git a/package/firmware/fritz-tools/Makefile b/package/firmware/fritz-tools/Makefile
deleted file mode 100644
index 4891dcaca3..0000000000
--- a/package/firmware/fritz-tools/Makefile
+++ /dev/null
@@ -1,30 +0,0 @@
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=fritz-tools
-PKG_RELEASE:=1
-CMAKE_INSTALL:=1
-PKG_FLAGS:=nonshared
-
-include $(INCLUDE_DIR)/package.mk
-include $(INCLUDE_DIR)/cmake.mk
-
-define Package/fritz-tools
- SECTION:=firmware
- CATEGORY:=Firmware
- DEPENDS:=@TARGET_ipq806x +zlib
- TITLE:=Utilites for accessing AVM Calibration data and TFFS
-endef
-
-define Package/fritz-tools/description
- This package contains:
- fritz_cal_extract.c: tool to extract WLAN calibration data.
- fritz_tffs_read.c: partially read the TFFS filesystems.
-endef
-
-define Package/fritz-tools/install
- $(INSTALL_DIR) $(1)/usr/bin
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/fritz_cal_extract $(1)/usr/bin/
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/fritz_tffs_read $(1)/usr/bin/
-endef
-
-$(eval $(call BuildPackage,fritz-tools))