aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2023-08-28 23:41:43 +0100
committerDaniel Golle <daniel@makrotopia.org>2023-09-04 23:00:35 +0100
commitd052d409a0689574b798cb6544ec6c7edd88d38f (patch)
tree268fb1ea396b8199c7b095b8f2b80c07d9f7647a /package/boot
parent3967c26974069fdc6ee216c8aeb9bc81cca4352b (diff)
downloadupstream-d052d409a0689574b798cb6544ec6c7edd88d38f.tar.gz
upstream-d052d409a0689574b798cb6544ec6c7edd88d38f.tar.bz2
upstream-d052d409a0689574b798cb6544ec6c7edd88d38f.zip
uboot-mediatek: fix dependency on TF-A for MT7988 RFB (sdmmc)
The U-Boot build for the MT7988 reference board booting from SD card wrongly depended on the 'ddr4' variant of the ARM TrustedFirmware-A build even though the 'comb' variant is used. Fix that dependency. Fixes: 572ea68070 ("uboot-mediatek: add patches for MT7988 and builds for RFB") Signed-off-by: Daniel Golle <daniel@makrotopia.org> (cherry picked from commit 78e3adcaf993cd1a58821a69efccfca8d380f754)
Diffstat (limited to 'package/boot')
-rw-r--r--package/boot/uboot-mediatek/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/boot/uboot-mediatek/Makefile b/package/boot/uboot-mediatek/Makefile
index 021d444a97..66de392185 100644
--- a/package/boot/uboot-mediatek/Makefile
+++ b/package/boot/uboot-mediatek/Makefile
@@ -403,7 +403,7 @@ define U-Boot/mt7988_rfb-sd
BL2_BOOTDEV:=sdmmc
BL2_SOC:=mt7988
BL2_DDRTYPE:=comb
- DEPENDS:=+trusted-firmware-a-mt7988-sdmmc-ddr4
+ DEPENDS:=+trusted-firmware-a-mt7988-sdmmc-comb
endef
UBOOT_TARGETS := \