aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-omap/patches/103-disable-fat-write-spl.patch
diff options
context:
space:
mode:
authorAndre Heider <a.heider@gmail.com>2019-09-06 11:25:30 +0200
committerAlexander Couzens <lynxis@fe80.eu>2019-11-20 10:46:19 +0100
commitb69df1eee0eb4618355d5ea4d0cdb4553475c4b7 (patch)
tree495c0252af31d905eeb7faef6d8805db878c59b0 /package/boot/uboot-omap/patches/103-disable-fat-write-spl.patch
parent65cfe8164ae9e3965e45d68dd9649fc9784dc2a0 (diff)
downloadupstream-b69df1eee0eb4618355d5ea4d0cdb4553475c4b7.tar.gz
upstream-b69df1eee0eb4618355d5ea4d0cdb4553475c4b7.tar.bz2
upstream-b69df1eee0eb4618355d5ea4d0cdb4553475c4b7.zip
omap: update uboot to 2019.10
All patches have been dropped, they're either redundant (e.g. due to the new and unset CONFIG_SPL_FAT_WRITE), break compilation (thumb hacks) or have been applied upstream. The defconfig for am335x_boneblack has been removed upstream [0], so use am335x_evm for boneblack too. Size changes (before, after, file): ti_am335x-evm and ti_am335x-bone-black: 79804 110832 MLO 623836 756148 u-boot.img ti_omap3-beagle: 54148 57708 MLO 496272 665728 u-boot.img ti_omap4-panda: 39356 40204 MLO 284648 366672 u-boot.img Tested on boneblack, which has the biggest spl size increase. The beagle and panda spl sizes seem reasonable to not break booting. [0] https://gitlab.denx.de/u-boot/u-boot/commit/8fa7f65dd02c176ee6021eaf40114560b8954ba2 Signed-off-by: Andre Heider <a.heider@gmail.com>
Diffstat (limited to 'package/boot/uboot-omap/patches/103-disable-fat-write-spl.patch')
-rw-r--r--package/boot/uboot-omap/patches/103-disable-fat-write-spl.patch27
1 files changed, 0 insertions, 27 deletions
diff --git a/package/boot/uboot-omap/patches/103-disable-fat-write-spl.patch b/package/boot/uboot-omap/patches/103-disable-fat-write-spl.patch
deleted file mode 100644
index 89b02044dc..0000000000
--- a/package/boot/uboot-omap/patches/103-disable-fat-write-spl.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-Index: u-boot-2017.01/fs/fat/Makefile
-===================================================================
---- u-boot-2017.01.orig/fs/fat/Makefile
-+++ u-boot-2017.01/fs/fat/Makefile
-@@ -4,8 +4,8 @@
- #
-
- obj-$(CONFIG_FS_FAT) := fat.o
--obj-$(CONFIG_FAT_WRITE):= fat_write.o
-
- ifndef CONFIG_SPL_BUILD
-+obj-$(CONFIG_FAT_WRITE):= fat_write.o
- obj-$(CONFIG_FS_FAT) += file.o
- endif
-Index: u-boot-2017.01/fs/fat/fat.c
-===================================================================
---- u-boot-2017.01.orig/fs/fat/fat.c
-+++ u-boot-2017.01/fs/fat/fat.c
-@@ -163,7 +163,7 @@ static void get_name(dir_entry *dirent,
- }
-
- static int flush_dirty_fat_buffer(fsdata *mydata);
--#if !defined(CONFIG_FAT_WRITE)
-+#if !defined(CONFIG_FAT_WRITE) || defined(CONFIG_SPL_BUILD)
- /* Stub for read only operation */
- int flush_dirty_fat_buffer(fsdata *mydata)
- {